Simpler Navigation coming for Servers and Operating Systems
Coming soon: a much simpler Servers and Operating Systems section of the Community. We will combine many of the older boards, and you won't have to click through so many levels to get at the information you need. If you are looking for an older board and do not find it, check the consolidated boards, as the posts are still there.
Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

Can not run the Oracle Installer for 8.1.7.3 patch.

SOLVED
Go to solution
Gino Castoldi_2
Honored Contributor

Can not run the Oracle Installer for 8.1.7.3 patch.

Hi,

HP-UX 11.0 Oracle 8.1.7.0 OVO 6.14.

We recently upgraded Oracle for OpenView 8.0.6 to 8.1.7.0. The next step according to HP documentation is to install the Oracle patch 8.1.7.3.

When we run the Oracle Installer (/cdrom/runInstaller) (as user oracle)
it gets this message:

"There are no patches that need to be applied from the patch set Oracle 8i
Patch Set 8.1.7.3.0"

When I click on the "installed products.." icon it returns nothing.
It seems that the Oracle Installer thinks that Oracle 8.1.7.0 is not installed for some unknown reason, but it is.

The environment variables are set in root and oracle for Oracle 8.1.7. I can start up the Oracle database (svrmgrl; lsnrctl start).
VPO 6.14 runs fine with Oracle 8.1.7.0.

Any ideas on what could be the problem?

10 points to any good answer.
Thank you
Gino

8 REPLIES
Bernhard Mueller
Honored Contributor
Solution

Re: Can not run the Oracle Installer for 8.1.7.3 patch.

Gino,

just a guess, but would it be possible you got the wrong patch file (ie. 8.1.7.3 for 32bit instead of 64bit or vice vesa)?

Regards
Bernhard
Massimo Bianchi
Honored Contributor

Re: Can not run the Oracle Installer for 8.1.7.3 patch.

Hi, check these out:

- oracle creates a file in /var/opt/oracle/..something,
with the location of the oracle installer files.

if this files is not readacle with the user you start the installer, it won't find nothing to patch


- remember where you put the catalog of the installer, it is of vital importance. Even if you properli installed oracle, but then you trhow away those files, the only way is to reinstall oracle (sigh). in my case, oracle+sap, these files are located in
/oracle; there you find directories like oui, stage, and oraInventory , most important.

The content of /var/opt/oracle/.... must point to this directory.

HTH,
Massimo



Steven E. Protter
Exalted Contributor

Re: Can not run the Oracle Installer for 8.1.7.3 patch.

This problem is usually triggered by the environment variables of the user you are using to do the installation.

We have a user called oracle that owns the database and does all installations.

The key variables are ORACLE_HOME ORACLE_SID and a few others

These variables point to the location of the oracleInventory database of installed products.

Look at the system and all the variables starting with ORA for taht user(env | grep ORA) and check out the oracle base directory. Find the oracleInventory directy is present has appropriate permissions and that the appropriate environment variables point to it.

Other alternative: Its already installed?

Suggestion: Either way, go all the way to 8.1.7.4.0, its the stable, fully patched released and based on our experience extremely reliable on 11.11 systems.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
V.Tamilvanan
Honored Contributor

Re: Can not run the Oracle Installer for 8.1.7.3 patch.

Hi,
It is only environment problem. You need to check once again properly the oracle environment.
Gino Castoldi_2
Honored Contributor

Re: Can not run the Oracle Installer for 8.1.7.3 patch.

Hi,

The problem is solved.
The file /var/opt/oracle/oraInst.loc had the
wrong path for the "inventory_loc=" variable.
After I changed the path the Oracle Installer
started and is now working fine.

Thank you again.
Gino
Yogeeraj_1
Honored Contributor

Re: Can not run the Oracle Installer for 8.1.7.3 patch.

hi,

Hopefully, you had your inventory directory still available.

I had a similar problem where there was no inventory! Someone had deleted it and was getting the same message.

We had to unmount the existing ORACLE_HOME and reinstall on a different home just to re-create the inventory. After that discarding the new installation and linking the repository the old installation fixed that issue.

BTW, why not install 8.1.7.4? [this is the recommended patchset for this release]

regards
Yogeeraj
No person was ever honoured for what he received. Honour has been the reward for what he gave (clavin coolidge)
Jeroen Peereboom
Honored Contributor

Re: Can not run the Oracle Installer for 8.1.7.3 patch.

I'm curious if you have an installation instruction...
Is so, I'm interested...

JP
twang
Honored Contributor

Re: Can not run the Oracle Installer for 8.1.7.3 patch.

Look ahead, apply the 8.1.7.4 patchset (2376472) and upgrade the database to 8174 which is oracle recommended latest patch level(8i).