cancel
Showing results for 
Search instead for 
Did you mean: 

Connection problem

Filosofo
Regular Advisor

Connection problem

Hello guys,
I have an Oracle RAC 9.2.0.3 and, after a client and server reboot, when I try to logon with user pluto trought sqlplus / I see this message:

ORA-01017: invalid username/password; logon denied

But before of the reboot this command function correctly.
Please help me

Filo

PS I don't Know Oracle
Sistem engeneer expert
18 REPLIES
Patrick Wallek
Honored Contributor

Re: Connection problem

Is the DB you are trying to connect to up?

# ps -ef | grep pmon

You should see a process for the DB. If the DB isn't started, then you, or someone, needs to start it.
Massimo Bianchi
Honored Contributor

Re: Connection problem

And check the listener, if you are on the other node !

ps -ef | grep -i lsn

Massimo
Steven E. Protter
Exalted Contributor

Re: Connection problem

To start oracle

log on as the oracle application owner(check the binaries for ownership)

database

check /etc/oratab for instance name

echo $ORACLE_SID

change as needed

sqlplus internal

select * from v$instance;

# make sure ORACLE_SID is set right

startup

quit or exit

lsnrctrl startup

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Hein van den Heuvel
Honored Contributor

Re: Connection problem


This is (IMHO) clearly an operational/usage question in your production environment.
We can all poke here at the problem with various more or less clever OS and Oracle questions and suggestions but in the end the solution will have to come from your own production environment. So just got there now?!
Please contact you own operational folks (hopefully that is not you!).

Oracle RAC has the potential and intend to handle individual server reboots completely transparently. Please question ypur local staff why this is not happening. Maybe some consultancy is in order, maybe it was a bad-luck glitch.

Regards,
Hein.
Filosofo
Regular Advisor

Re: Connection problem

Thanks for helps,
I see the DataBase situation and I see that is Up an running like listener...infect if I try to execute sqlplus system/manager I log to DB.
Is possible that oracle user not exist?
What can I do to verify if the oracleuser exist?

Thanks

Filo
Sistem engeneer expert
Massimo Bianchi
Honored Contributor

Re: Connection problem

Hi,
there are some points:

- in oracle 9 the user "internal" no more exists

- to check if a particular user exists, use

sqlplus system/manager
select username from dba_users;

pay attention that using "/" you are using external authentication, so you must search for an entry like ops$

- in case, it's better to specify the oracle sid you are attempting to login into

sqlplus /@

Massimo
Massimo Bianchi
Honored Contributor

Re: Connection problem

last and least

"This member has assigned points to 42 of 267 responses to his/her questions"

Since you like ITRC forum and its help, it would be a good thing to attain to its etiquette and assign some points. Not to me, but in general :)

Massimo
Filosofo
Regular Advisor

Re: Connection problem

This is tha output of command:
select username from dba_users;
SQL> select username from dba_users;

USERNAME
------------------------------
SYS
SYSTEM
OUTLN
DBSNMP
WMSYS

SQL>


I think that tha user not exist....
What can I do to create?

Massimo, is true that you said about the points assigned....but when I write on the forum, I am in a " sea of disagreeableness " and I think to solve my problem quickly....But from Now I TRY to assigned point for the helps...
Excuse me for my INCORRECT conduct.

Thanks

Filosofo
Sistem engeneer expert
Massimo Bianchi
Honored Contributor

Re: Connection problem

Hi,

i need to know the exact O.S. user you are using, and the owner of the oracle executable.

The "/" login without password is only allowed for the oracle of the $ORACLE_HOME/bin/oracle executable.

From the output of your query i do not see any external user.
Are you connected with that user ?

Massimo
Filosofo
Regular Advisor

Re: Connection problem

No I'm not Connect....end the name of the OS user is like the name of the oracle user...

Thanks

Filo
Sistem engeneer expert
Massimo Bianchi
Honored Contributor

Re: Connection problem

are you able to connect with

sqlplus /@SID

?


try from both server.


Massimo Bianchi
Honored Contributor

Re: Connection problem

Well,
if you want to create that user, i will give you the instructions, but it's more a dba work.


sqlplus system/manager


create user ops$ identified by default tablespace temporary tablespace ;
grant connect, resource to ops$;
commit;


But, it's a dba-question....Once this is resolved, there may be other issues.

Massimo
Filosofo
Regular Advisor

Re: Connection problem

Hi,
I try to connect like oracle user on server db and I execute sqlplus /@ORACLESID...but I see the some message

ORA-01017.....

Thanks

Filo
Sistem engeneer expert
Massimo Bianchi
Honored Contributor

Re: Connection problem

Was there any change in the $ORACLE_HOME/dbs/initSID.ora file ?

are you sure that the instance is opened read/write ? check with

sqlplus system/manager

select * from v$instance;
select * from v$database;


and from the alert_SID.log .

Massimo

Filosofo
Regular Advisor

Re: Connection problem

I see from the commands:

select * from v$istance;
select * from v$istance
*
ERROR at line 1:
ORA-00942: table or view does not exist


and

-------------------- -------- ----------- ---------------- ------------------
SWITCHOVER_STATUS DATAGUAR GUARD_S SUP SUP SUP FOR
------------------ -------- ------- --- --- --- ---
23-JUL-03 NOT ALLOWED 18-JUL-03 READ WRITE MAXIMUM PERFORMANCE

DBID NAME CREATED RESETLOGS_CHANGE# RESETLOGS
---------- --------- --------- ----------------- ---------
PRIOR_RESETLOGS_CHANGE# PRIOR_RES LOG_MODE CHECKPOINT_CHANGE


Thanks

Filo
Sistem engeneer expert
Massimo Bianchi
Honored Contributor

Re: Connection problem

Hi,
the instance is open properly.


I did a misstype:

select * from v$instance;

(with the _n_ )

You said Oracle RAC. It's on one or two nodes ?
if two nodes, do one works well or both fail ?

You said client/server reboot. What is the client application that will use oracle ?

Massimo
Filosofo
Regular Advisor

Re: Connection problem

RAC on two nodes, and on the nodes the situation is ugual.
The output is :

SQL> select * from v$instance;

INSTANCE_NUMBER INSTANCE_NAME
--------------- ----------------
HOST_NAME
----------------------------------------------------------------
VERSION STARTUP_T STATUS PAR THREAD# ARCHIVE LOG_SWITCH_
----------------- --------- ------------ --- ---------- ------- -----------
LOGINS SHU DATABASE_STATUS INSTANCE_ROLE ACTIVE_ST
---------- --- ----------------- ------------------ ---------
1 GBCREG1
h3rmh129
9.2.0.3.0 23-JUL-03 OPEN YES 1 STOPPED
ALLOWED NO ACTIVE PRIMARY_INSTANCE NORMAL


SQL>

and on tha client there is oracle 9.2

Thanks

Filo
Sistem engeneer expert
Yogeeraj_1
Honored Contributor

Re: Connection problem

hi,

is the problem solved now?

To add to the excellent replies by Massimo,

note that on the client, you must ensure that the tnsname entries are correct.

can you also post the output of:

show parameter os

(you may connect as / as sysdba to get that)


cheers
Yogeeraj
No person was ever honoured for what he received. Honour has been the reward for what he gave (clavin coolidge)