Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

DBD-Oracle1.15..installation fails

SOLVED
Go to solution
Joseph P. Marino
Occasional Advisor

DBD-Oracle1.15..installation fails

OK I am back installed 5.8.5 went gooood
copmiled...everything OK
Installed DBI 1.45 ...looking good

Start installing DBD-Oracle1.15

and on make test it fails
I included output of perl -V
attachement error message for make test


# perl -V
Summary of my perl5 (revision 5 version 8 subversion 5) configuration:
Platform:
osname=hpux, osvers=11.11, archname=PA-RISC2.0
uname='hp-ux mpc120 b.11.11 u 9000800 2660268794 unlimited-user license '
config_args='-de'
hint=recommended, useposix=true, d_sigaction=define
usethreads=undef use5005threads=undef useithreads=undef usemultiplicity=undef
useperlio=define d_sfio=undef uselargefiles=define usesocks=undef
use64bitint=undef use64bitall=undef uselongdouble=undef
usemymalloc=n, bincompat5005=undef
Compiler:
cc='cc', ccflags =' -Ae -D_HPUX_SOURCE -Wl,+vnocompatwarnings -D_LARGEFILE_SOURCE ',
optimize='-O2',
cppflags='-Aa -D__STDC_EXT__ -D_HPUX_SOURCE -Ae -D_HPUX_SOURCE -Wl,+vnocompatwarnings'
ccversion='B.11.11.02', gccversion='', gccosandvers=''
intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=4321
d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16
ivtype='long', ivsize=4, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=4
alignbytes=8, prototype=define
Linker and Libraries:
ld='/usr/bin/ld', ldflags =' -L/usr/local/lib'
libpth=/usr/local/lib /lib /usr/lib /usr/ccs/lib
libs=-lnsl -lnm -lndbm -lmalloc -ldld -lm
perllibs=-lnsl -lnm -lmalloc -ldld -lm
libc=/lib/libc.sl, so=sl, useshrplib=false, libperl=libperl.a
gnulibc_version=''
Dynamic Linking:
dlsrc=dl_hpux.xs, dlext=sl, d_dlsymun=undef, ccdlflags='-Wl,-E -Wl,-B,deferred '
cccdlflags='+Z', lddlflags='-b +vnocompatwarnings -L/usr/local/lib'


Characteristics of this binary (from libperl):
Compile-time options: USE_LARGE_FILES
Built under hpux
Compiled at Oct 26 2004 12:34:58
@INC:
/opt/perl5/lib/5.8.5/PA-RISC2.0
/opt/perl5/lib/5.8.5
/opt/perl5/lib/site_perl/5.8.5/PA-RISC2.0
/opt/perl5/lib/site_perl/5.8.5
/opt/perl5/lib/site_perl
4 REPLIES
David Bell_1
Honored Contributor

Re: DBD-Oracle1.15..installation fails

Joseph,

This may be way off base but check to see if the lwp libraries are included in the 5.8.5 version. You may want to download the latest HP version for HP-UX 11i from the software depot located at:

http://software.hp.com/portal/swdepot/displayProductInfo.do?productNumber=PERL

Hope this helps,

Dave
Ermin Borovac
Honored Contributor
Solution

Re: DBD-Oracle1.15..installation fails

I think that your problem is described in README.hpux in DBD::Oracle distribution. Solution is to recompile perl and link with libcl and libpthread libraries.

If you are running perl Configure interactively then when asked the question:

What libraries to use? - Answer by prepending (i.e. at the beginning): -lcl -lpthread

For example:
What libraries to use? [-lnsl -lnm -lndbm -lmalloc -ldld -lm -lc -lndir -lcrypt -lsec] -lcl -lpthread -lnsl -lnm -lndbm -lmalloc -ldld -lm -lc -lndir -lcrypt -lsec

Alternatively you can run Configure as follows.

$ sh Configure -des -A prepend:libswanted='cl pthread '
H.Merijn Brand (procura
Honored Contributor

Re: DBD-Oracle1.15..installation fails

1. Ermins answer is correct, and you can see that you didn't in the -V output:

libs=-lnsl -lnm -lndbm -lmalloc -ldld -lm
perllibs=-lnsl -lnm -lmalloc -ldld -lm

2. Do not attach .doc files if you want help. Plain text. *I* will not read .doc attachments, and I am considered the perl DBI/DBD guru here, so you /could/ miss some info

3. DBD-Oracle-1.16 is released this week. If you are going to have to deal with Unicode or non-standard encodings I strongly advise to get it

4. Read README.hpux (or do man perlhpux) in the perl distribution *and* in the DBD-Oracle distribution.

Enjoy, Have FUN! H.Merijn
Enjoy, Have FUN! H.Merijn
Joseph P. Marino
Occasional Advisor

Re: DBD-Oracle1.15..installation fails

Thanks guys

This was very helpfull
Next time no .doc