Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

Database compatibility Question

Waqar Razi
Regular Advisor

Database compatibility Question

I am working on upgrade of OS on hp ux servers. I have few questions about database compatibility:

1- Is oracle 9.2.0 is supported on hpux 11.31?

2- Is Oracle 8.1.7 supported on hpux 11.11, 11.23 and 11.31? If not, on what versions of hpux it is supported?

3- If I want to migrate from oracle 8.1.7 to oracle 9.2.0, what are the steps and considerations I have to take before doing that?


Regards,

Razi
7 REPLIES
Steven E. Protter
Exalted Contributor

Re: Database compatibility Question

Shalom,

1) My understanding is that all supported oracle versions are now certified with 11.31.

2) Oracle 8.1.7 is not supported on HP-UX 11.31 because it was de-supported by Oracle before 11.31 was released. It might work, but technically its not supported on any OS any more from the oracle perspective.

3) That migration involves a data migration/conversion. There is a 26 step conversion plan on Oracles metalink site. My DBA did this once for me back in 2005.

Note if you are planning a migration you might want to think about Oracle 10g. Oracle 9.2.0 is nearing the end of its support life cycle.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Waqar Razi
Regular Advisor

Re: Database compatibility Question

Could you please send me the link for 26 step migration plan?

Also when is the end of support for oracle 9.2.0?

Could you also please refer some plan for database migration from 8.1.7 to 10g and also from 9.2.0 to 10g?
Patrick Wallek
Honored Contributor

Re: Database compatibility Question

You should really be checking with Oracle on these questions.

Oracle 8i is currently out of support completely, so there will be NO support for it on 11.31. It may work, but if you have problems you are on your own.

I believe Oracle 9i is almost out of support as well. Again, it may work, but you would be on your own if you have problems.

If I were looking to migrate, I would be looking to go to Oracle 10gR2 or 11g.

Oracle has some good documentation about upgrading and migrating. You should have a look at it.
Oviwan
Honored Contributor

Re: Database compatibility Question

hey

have you access to http://metalink.oracle.com? there you will find all this information. for example under the certify link...

Regards
Deepak Kr
Respected Contributor

Re: Database compatibility Question

Good to go with Oracle 10g now!!

Older versions will be out of support matrix soon.
"There is always some scope for improvement"
Yogeeraj_1
Honored Contributor

Re: Database compatibility Question

hi Razi,

I would 'upgrade' directly to 11g. Anyway, before you upgrade to any version, you should ensure that your applications will continue to work with the new version of Oracle database.

OF course, newer version will consume more resources as compared to the version you have. So bear in mind that you may have to upgrade you hardware resources before the database upgrade.

If you need any further assistance, please let us know.

kind regards
yogeeraj
No person was ever honoured for what he received. Honour has been the reward for what he gave (clavin coolidge)
Volker Borowski
Honored Contributor

Re: Database compatibility Question

Hi,

Customer Care Support for 9.2 ended 31.07.2007.
It was extended at no additional Cost until 31.07.2008 (at least for SAP Customers).

If you want to use 9.2 right now and receive support, you need to be on extended maintanance (which will require additional cost). As far as I know, you can extend until 2010.

I'd recommend to go to 10g if your application permits.

Best regards
Volker