Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

Error installing Oracle 9.2 on HP-UX 11.11

ABalashov
Occasional Visitor

Error installing Oracle 9.2 on HP-UX 11.11

Hi all
I am trying to install Oracle 9.2.0.1 on a HP-UX 11.11 System. The installation went through completely But during the linking Phase, I ended up in the error
"Error in invoking target install of the makefile /net/oracle/product/9.2.0/sqlplus/lib/ins_sqlplus.mk
"

Can someone help me out with this?

My server:
HP-UX/System

Model

echo Modelstring: [9000/800/A400-6X]; echo Number of CPUs: 1; echo CPU
captable: 64 bits;echo CPU Speed: 650 MHz;

Modelstring: [9000/800/A400-6X]
Number of CPUs: 1
CPU captable: 64 bits
CPU Speed: 650 MHz
PA-RISC Type (11.x)
HP-UX hp B.11.11 U 9000/800 845927851 unlimited-user license
HP-UX 32/64 = 64 bits

Physical Memory

sical: 655360 Kbytes, lockable: 457300 Kbytes, available: 530344 Kbytes
14 REPLIES
Ian Lochray
Respected Contributor

Re: Error installing Oracle 9.2 on HP-UX 11.11

Metalink reports many errors like the one you encountered. The most common cause seems to be a lack of swap space. Is there enough swap on your system and is the kernel tuned so that it can all be used?
Also, check the syslog for any O/S errors that may be related.
Cheryl Griffin
Honored Contributor

Re: Error installing Oracle 9.2 on HP-UX 11.11

http://bizforums.itrc.hp.com/cm/QuestionAnswer/0,,0xc40e543254bfd611abdb0090277a778c,00.html
same error different version and some things to check.
"Downtime is a Crime."
Cheryl Griffin
Honored Contributor

Re: Error installing Oracle 9.2 on HP-UX 11.11

Also check your release notes for your version. Here's another older link http://os.cc.biu.ac.il/documentation/oracle/8.1.7_doc/relnotes/A86838_01.pdf but it says that this type of error is a known installation problem.

From that link:
Known Upgrade Issues
An attempt to upgrade an Oracle8i Release 2 (8.1.6) database to a Release 3 (8.1.7) database in the same ORACLE_HOME will produce
ignorable installation runtime errors that occur during the deinstallation of the 8.1.6 software. Refer to bug 1344446 for more
information.
Oracle Universal Installer treats a software upgrade as a deinstall of the old software followed by an install of the new software. The errors that occur during upgrade in the same ORACLE_HOME appear as relinking errors in the RDBMS and Net8 Server. Since these errors are relinking errors which occur during the deinstall of the 8.1.6 software and since the affected files will be replaced and relinked again when the 8.1.7 software is installed, these errors can be safely ignored.
During upgrade of the software, Oracle Universal Installer will display
error dialogs with the following messages:
Error in invoking target ioracle of make file
/rdbms/lib/ins_rdbms.mk
Error in invoking target install of make file
/network/lib/ins_net_server.mk
Clicking the [Ignore] button on each of these dialogs allows the installation to continue.
Avoid these errors by installing the Release 3 (8.1.7) software into a new ORACLE_HOME, then performing the data upgrade as usual.
"Downtime is a Crime."
Jeff Schussele
Honored Contributor

Re: Error installing Oracle 9.2 on HP-UX 11.11

Hi Balashov,

The newer Oracle installs are notorious memory & swap hogs.
It's advised that for the install you have swap set for at least 2 X memory.
Check the Oracle install log & syslog.log for ENOMEM errors. If so that would indicate that you ran out.

Rgds,
Jeff
PERSEVERANCE -- Remember, whatever does not kill you only makes you stronger!
ABalashov
Occasional Visitor

Re: Error installing Oracle 9.2 on HP-UX 11.11

I have 1280 Mb of swap.
Used - 4%.

In the syslog of mistakes it is not revealed.

At somebody it has turned out to establish version 9.2.0.1?

I installed patches:
PHCO_26466, PHCO_27772, PHKL_24253, PHKL_25652, PHKL_25728, PHKL_25729, PHKL_27092, PHKL_27092, PHKL_27094, PHKL_27096, PHKL_27317, PHSS_26558,
PHSS_26560
There are messages in $ORACLE_HOME/install/make.log.

/usr/ccs/bin/make -f ins_sqlplus.mk install ORACLE_HOME=/net/oracle/product/9.2.0
rm -f sqlplus
chmod 755 /net/oracle/product/9.2.0/bin/demobld
chmod 755 /net/oracle/product/9.2.0/bin/demodrop
chmod 755 /net/oracle/product/9.2.0/bin/helpins
chmod 755 /net/oracle/product/9.2.0/bin/pupbld
Linking sqlplus
rm -f sqlplus
cc -Wl,+s -Wl,+n +DA2.0W +DS2.0 -o sqlplus -L/net/oracle/product/9.2.0/sqlplus/lib/ -L/net
ld: Unsatisfied symbol "gethrtime" in file /net/oracle/product/9.2.0/lib//libgeneric9.a[kgl2.o]
1 errors.
*** Error exit code 1

Stop.
Ian Lochray
Respected Contributor

Re: Error installing Oracle 9.2 on HP-UX 11.11

Here is Oracle's answer to the gethrtime issue. I hope the formatting is OK.



Bookmark Fixed font Go to End

Doc ID: Note:159789.1
Subject: Error Relinking on HP/UX 64bit: ld: Unsatisfied symbol "gethrtime"
Type: PROBLEM
Status: PUBLISHED
Content Type: TEXT/PLAIN
Creation Date: 04-OCT-2001
Last Revision Date: 08-MAY-2003


Problem Description ------------------- You are relinking the Oracle software(either manually or as part of an install) on HP/UX 64-bit and receive errors similar to the following: 9.0.1.x: ld:Unsatisfied symbol "gethrtime" in file $ORACLE_HOME/lib//libserver9.a[kcrf.o] 1 errors. 9.2.0.1: cc: warning 487: Possibly incorrect message catalog. ld: Unsatisfied symbol "gethrtime" in file /opt/oracle/product/9.2.0/lib//libserver9.a[kcrr.o] 1 errors. Solution Description -------------------- HP/UX patches PHCO_23770, PHCO_23092 must be applied. For details on these patches, please contact HP for assistance. Explanation ----------- The gethrtime(void) function is a new funtion in libc and is not present in older versions of libraries, so this issue did not appear in prior versions. The referenced HP patches resolve the linking errors. References ---------- Note: 149556.1 Bug: 1829872 Quick Installation Guide for HP-UX (Part number: A90351-01)
.

--------------------------------------------------------------------------------

Copyright (c) 1995,2000 Oracle Corporation. All Rights Reserved. Legal Notices and Terms of Use.

Indira Aramandla
Honored Contributor

Re: Error installing Oracle 9.2 on HP-UX 11.11

Hi,

The reasons for the errors may be due to one of the following:

1. Insufficient swap space.
Check if you have enough swap space. Do you have the contiguous chunk of swap space.

2. Defining environment variables and linking
Make that you are current on all the O/S patches. and all the libraries. Make sure you set your PATH correctly. /usr/lib , /usr/ccs/bin , /usr/ccs/lib, LD_LIBRARY_PATH, and relink the executables.

3. If you have Internet Application Server installed then Oracle 9i and the 9iAS (Application Server) cannot share the same ORACLE_HOME. If you have installed other Oracle products, then Oracle 9.2.0 must be installed in a different ORACLE_HOME.

4. Patching libc on HP may solve the problem.


Hope this helps.
Never give up, Keep Trying
ABalashov
Occasional Visitor

Re: Error installing Oracle 9.2 on HP-UX 11.11

4. Patching libc on HP may solve the problem.


What patch I should apply?
Indira Aramandla
Honored Contributor

Re: Error installing Oracle 9.2 on HP-UX 11.11

When you asked 4. which patch, does that mean 1,2 and 3 options are not the issue in your case.

Attached document has few suggestions from a previous forum on similar grounds.

Please refer to Oracle and HP before you descide the correct patch bundle level. This is only a suggestion.
Never give up, Keep Trying
Peter Fuchs
Occasional Visitor

Re: Error installing Oracle 9.2 on HP-UX 11.11

Hi,

if I remember correctly, I encountered the same problem during our Oracle installation on HP-UX (same release). The following symbolic links solved my problems:

cd /usr/lib
ln -s /usr/lib/libX11.3 libX11.sl
ln -s /usr/lib/libXIE.2 libXIE.sl
ln -s /usr/lib/libXext.3 libXext.sl
ln -s /usr/lib/libXhp11.3 libXhp11.sl
ln -s /usr/lib/libXi.3 libXi.sl
ln -s /usr/lib/libXm.4 libXm.sl
ln -s /usr/lib/libXp.2 libXp.sl
ln -s /usr/lib/libXt.3 libXt.sl
ln -s /usr/lib/libXtst.2 libXtst.sl

This was the official recommendation by Oracle (as far as I remember).


Best regards,

Peter
Peter Fuchs
Occasional Visitor

Re: Error installing Oracle 9.2 on HP-UX 11.11

Hi again,

just forgot to tell... after creating the links you will need either to reinstall Oracle. I may be sufficient to re-execute the linking process (log in as oracle user and execute "relink all").


Regards,

Peter
T G Manikandan
Honored Contributor

Re: Error installing Oracle 9.2 on HP-UX 11.11

This is definitely a problem with no proper pre-requisite patches.

check for the pre-requisite "libc" patches for the oracle installation.

I will revert if I find the document

Thanks
T G Manikandan
Honored Contributor

Re: Error installing Oracle 9.2 on HP-UX 11.11

Just check your "doc" dir in the installation CD.

There you have the pre-requisite patches.

check that for hpux11.11 and not for other versions

Thanks
T G Manikandan
Honored Contributor

Re: Error installing Oracle 9.2 on HP-UX 11.11