Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

Error on install Oracle 9i Server

SOLVED
Go to solution
uadm26
Super Advisor

Error on install Oracle 9i Server

Hi,

In midle of installation of Oracle 9i Server it's start report that error:

Error in invoking target install of makefile /opt/oracle92/ctx/lib/ins_ctx.mk

Do u will have seen something similar before?

Thanks. Joel
7 REPLIES
Steven E. Protter
Exalted Contributor

Re: Error on install Oracle 9i Server

This can happen for a few reasons:

1) Not enough space on the target filesystem
2) Pre-requisite patches for the linker and compilers not installed.
3) SHLIB_PATH not correct for the user doing the install
4) Incorrect permissions for the user doing the install.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Eric Antunes
Honored Contributor

Re: Error on install Oracle 9i Server

Hi Joel,

See your make.log ($Oracle_Home/install/make.log) and check that you met all prerequests.
Each and every day is a good day to learn.
Michael Schulte zur Sur
Honored Contributor

Re: Error on install Oracle 9i Server

Hi,

are there any processes from a former installation still running?

greetings,

Michael
uadm26
Super Advisor

Re: Error on install Oracle 9i Server

I select the ignore option, cus i think the problem it's in variables declared, i'll gone take a look in makefile.log, and try to create a data base.
Thanks for everyting.
SG4
Occasional Visitor
Solution

Re: Error on install Oracle 9i Server

Hi,

I had the same problem you must do:

cd /usr/lib
ln -s /usr/lib/libX11.3 libX11.sl
ln -s /usr/lib/libXIE.2 libXIE.sl
ln -s /usr/lib/libXext.3 libXext.sl
ln -s /usr/lib/libXhp11.3 libXhp11.sl
ln -s /usr/lib/libXi.3 libXi.sl
ln -s /usr/lib/libXm.4 libXm.sl
ln -s /usr/lib/libXp.2 libXp.sl
ln -s /usr/lib/libXt.3 libXt.sl
ln -s /usr/lib/libXtst.2 libXtst.sl

and relink ctx
Indira Aramandla
Honored Contributor

Re: Error on install Oracle 9i Server

Hi Joel,

During the install of 9.x on HP-UX 11.x, you receive the following error:

"Error in invoking target install of makefile /ctx/lib/ins_ctx.mk"

You then check the $ORACLE_HOME/install/make.log and find errors similiar to the following:
===========================================================
cc -Wl,+s -Wl,+n -L/u01/app/oracle/product/9.0.1_64/ctx/lib [cutting line for brevity]
/usr/ccs/bin/ld: Can't find library for -lXm
Stop.
*** Error exit code 1
=========================================================== This error is raised when some of the shared libraries are missing in /user/lib. While installing Oracle 8i/9i on HP, the linker will look for libXm.sl,libXt.sl and libX11.sl when compiling the binary 'ctxhx'.

Check for the existence of these in /usr/lib and if they do not exist, please make the necessary symbolic links.

Solution Description

The linker (ld) cannot locate the X11/Motif shared libraries in /usr/lib.

1) Verify if libXm.sl exists in /usr/lib:

% cd /usr/lib
% ls -al libXm.sl

If this file does not exist, the linker will fail. It should be a symbolic link to another file, the base X11/Motif library.

2) Check for base X11/Motif libraries.

% ls -al libXm.*

lrwxr-xr-x 1 root sys 00:14 libXm.1@ -> /usr/lib/Motif1.2/libXm.1
lrwxr-xr-x 1 root sys 00:14 libXm.2@ -> /usr/lib/Motif1.2_R6/libXm.2
lrwxr-xr-x 1 root sys 00:14 libXm.3@ -> /usr/lib/Motif1.2_R6/libXm.3
lrwxr-xr-x 1 root sys 00:14 libXm.4@ -> /usr/lib/Motif2.1/libXm.4

Looking at the above, you see that libXm.* has several incarnations, libXm.1, libXm.2, etc. These are roughly the same shared library but different versions. If libXm.sl does not exist, a link must be made pointing to the most current library version. For example,
as libXm.4 comes from Motif 2.1, we can use it to create the shared library libXm.sl.

You can also simply use the highest numbered library i.e. libXm.4 is higher then libXm.3.

3) Create the shared library as a symbolic link to the base X11/Motif library.

% su root
% cd /usr/lib
% ln -s libXm.4 libXm.sl

OR

% ln -s /usr/lib/Motif2.1/libXm.4 /usr/lib/libXm.sl

Perform steps 1-3 for two other libraries, libXt.sl and libX11.sl.

4) Return to the installer and click RETRY.

Explanation

The necessary shared library does not exist in /usr/lib. For both Oracle8i and Oracle9i on HP, the linker will look for libXm.sl, libXt.sl AND libX11.sl when compiling the binary 'ctxhx'.

So long as the base X11/Motif libraries already exist, then symbolic links can be used. If the base X11/Motif libraries are missing, the necessary OS packages will have to be installed first.

I hope this helps


Indira A
Never give up, Keep Trying
Yogeeraj_1
Honored Contributor

Re: Error on install Oracle 9i Server

hi Joel,

if still not OK, see also metalink note: 151547.1

with subject: HP-UX: "Can't find library for -lXm" when installing 8i/9i or relinking executables

regards
Yogeeraj
No person was ever honoured for what he received. Honour has been the reward for what he gave (clavin coolidge)