Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

Failed to start GSD on one node in cluster

monto
Occasional Advisor

Failed to start GSD on one node in cluster

$ /usr/sbin/cmviewcl -v

CLUSTER STATUS
BOLTprod up

NODE STATUS STATE
hp206 up running

Network_Parameters:
INTERFACE STATUS PATH NAME
PRIMARY up 0/4/2/1 lan2

PACKAGE STATUS STATE AUTO_RUN NODE
ora_batch up running disabled hp206

Policy_Parameters:
POLICY_NAME CONFIGURED_VALUE
Failover configured_node
Failback automatic

Node_Switching_Parameters:
NODE_TYPE STATUS SWITCHING NAME
Primary up enabled hp206 (current)

PACKAGE STATUS STATE AUTO_RUN NODE
sqa_pkg1 up running disabled hp206

Policy_Parameters:
POLICY_NAME CONFIGURED_VALUE
Failover configured_node
Failback automatic

Node_Switching_Parameters:
NODE_TYPE STATUS SWITCHING NAME
Primary up enabled hp206 (current)

PACKAGE STATUS STATE AUTO_RUN NODE
batch_pkg up running disabled hp206

Policy_Parameters:
POLICY_NAME CONFIGURED_VALUE
Failover configured_node
Failback manual

Node_Switching_Parameters:
NODE_TYPE STATUS SWITCHING NAME
Primary up enabled hp206 (current)

NODE STATUS STATE
hp207 up running

Network_Parameters:
INTERFACE STATUS PATH NAME
PRIMARY up 0/1/2/0 lan0

PACKAGE STATUS STATE AUTO_RUN NODE
ora_online up running disabled hp207

Policy_Parameters:
POLICY_NAME CONFIGURED_VALUE
Failover configured_node
Failback automatic

Node_Switching_Parameters:
NODE_TYPE STATUS SWITCHING NAME
Primary up enabled hp207 (current)

PACKAGE STATUS STATE AUTO_RUN NODE
sqa_pkg2 up running disabled hp207

Policy_Parameters:
POLICY_NAME CONFIGURED_VALUE
Failover configured_node
Failback automatic

Node_Switching_Parameters:
NODE_TYPE STATUS SWITCHING NAME
Primary up enabled hp207 (current)

[prd1 hp207:/dnbusr1/oracle/dbadmin/log]
$


We have a oracle db on 9.2.0.8 on hpux(11.1)running with serviceguard.

[prd2 hp206:/pkg1/oracle/product]
$ /usr/sbin/swlist | grep -i serviceguard
B3935DA A.11.16.00 Serviceguard
B8325BA A.04.00 ServiceGuard Manager
T1859BA A.11.16.00 Serviceguard Extension for RAC


started gsd on node successfully ,but on node two its failing with error.
[prd1 hp207:/dnbusr1/oracle/dbadmin/log]
$ gsdctl start
Failed to start GSD on local node

i started the instance manually.is it going to be a problem if started manually?what could be the problem and how to fix it?please suggest.
2 REPLIES
Matti_Kurkela
Honored Contributor

Re: Failed to start GSD on one node in cluster

Start by reading the GSD log file:

$ORACLE_HOME/srvm/log/gsdaemon_.log

Perhaps there is a message explaining why GSD could not be started.

This question is more about Oracle RAC than Serviceguard, so the database section might be a better place for it. I'll ask the moderators to move this thread to the database section.

MK
MK
monto
Occasional Advisor

Re: Failed to start GSD on one node in cluster

i don't see any logs getting generated.on this node i see no oracle directory under /var/opt which will have srvConfig.loc and oraInst.loc.is this what causing GSD to not come up?