Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

HP-UX 11.0 to 11.11 Upgrade and Oracle 8.1.6

SOLVED
Go to solution
Bill Marmagas_1
Occasional Contributor

HP-UX 11.0 to 11.11 Upgrade and Oracle 8.1.6

I have Oracle 8.1.6 on HP-UX 11.0. Do I need to relink the Oracle binaries after an upgrade of the O/S from 11.0 to 11.11 (i.e., 11i)?
5 REPLIES
A. Clay Stephenson
Acclaimed Contributor

Re: HP-UX 11.0 to 11.11 Upgrade and Oracle 8.1.6

Hi:

I think the answer is that it depends on what libraries have been patched/upgraded on the two OS's. The easy answer is to simply relink to be safe. The data will be compatible even going from 32-bit to 64-bit (if that is the case).
If it ain't broke, I can fix that.
Jason VanDerMark
Trusted Contributor
Solution

Re: HP-UX 11.0 to 11.11 Upgrade and Oracle 8.1.6

Upgrade and then re-link to be on the safe side. All you need to do is:

make -f $ORACLE_HOME/rdbms/lib/ins_rdbms.mk procopt >logfile

You will need to do this for all of your libs, and binaries, which could be done quite quickly with a good script. I hope that this helps, and good luck with your upgrade.

Regards,
Jason V.
Tie two birds together, eventhough they have four wings, they cannot fly.
Bill Marmagas_1
Occasional Contributor

Re: HP-UX 11.0 to 11.11 Upgrade and Oracle 8.1.6

Thank you both for your quick responses! We will proceed with re-linking the Oracle binaries.
Bill Marmagas_1
Occasional Contributor

Re: HP-UX 11.0 to 11.11 Upgrade and Oracle 8.1.6

FYI: with Oracle 8.1, there is now a "relink all" command.
Jason VanDerMark
Trusted Contributor

Re: HP-UX 11.0 to 11.11 Upgrade and Oracle 8.1.6

Bill,

Wow! Thanks for the heads up on that. As you can probably tell, I haven't kept up with all the new goodies from 8i and 9i. Happy Holidays.

Regards,
Jason V.
Tie two birds together, eventhough they have four wings, they cannot fly.