Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

HP-UX Internet Express PostgreSQL (install error)

SOLVED
Go to solution
Yung_1
Occasional Visitor

HP-UX Internet Express PostgreSQL (install error)

I have installed HP-UX Internet Express PostgreSQL on HP9000 hpux B.11.11

$ echo $PGDATA
/var/opt/iexpress/postgresql
$ pg_ctl start
sh: 9417 Abort(coredump)
fgets failure: No such file or directory
The program "postgres" is needed by pg_ctl but was not found in the
same directory as "/opt/iexpress/postgresql/bin/pg_ctl".
Check your installation.

when I launch postmaster to check i have this result:
$ postmaster
/usr/lib/dld.sl: Unresolved symbol: pthread_mutex_lock (code) from postmaster
Abort

Can you help me ??

2 REPLIES
Dennis Handly
Acclaimed Contributor
Solution

Re: HP-UX Internet Express PostgreSQL (install error)

>The program "postgres" is needed by pg_ctl

Is postgres there?

>dld.sl: Unresolved symbol: pthread_mutex_lock

What does "chatr postmaster" show? Does it have libpthread?
What version of libc.2 do you have?
Yung_1
Occasional Visitor

Re: HP-UX Internet Express PostgreSQL (install error)

I have installed this patches and it seems to solve my problem :
PHCO_29816
PHCO_31923
PHCO_37294
PHCO_37369
PHKL_34805

thanks