Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

Informix and High System CPU usage

Mike Proulx
Occasional Contributor

Informix and High System CPU usage

I have a T520 with 10 CPUS/2048MB MEM running HP-UX 11.00 and Informix 7.31uc2. When Informix is running I have a excessive System CPU Utilization. The average of the 10 Processors is around 50% with a given processor with oninit attached to it can be as high as 75% System CPU utilization. The User Utilization is around 30%.

Does anyone have any ideas on what is causing this excessive CPU utilization.
2 REPLIES
Mike Proulx
Occasional Contributor

Re: Informix and High System CPU usage

I have one more bit if information to add to my question. While in glance I observed that the High System CPU utilization of the Informix processors seemed to be due to a high volume of vfaults.
Steve Lewis
Honored Contributor

Re: Informix and High System CPU usage

I don't know how experienced you are with Informix, but in case you are new to it, here are some pointers. Check that your SHMVIRTSIZE is big enough, with preferrably just the one V segment (onstat -g seg). Secondly check that you have enabled processor affinity which is supported on HP with IDS7.24 upwards. Thirdly, be aware that the main CPU VP does very little IO, farming it out to AIO VPs or kernel AIO. For this reason, CPU VPs never give way and always appear in the top listing. One other cause of high CPU usage in CPU VPs is sequential scans. Use oncockpit to check for these or select fromn sysmaster:syssqexplain where sqx_estcost is high. sar -d will also help look for these. Apart from that, 7.31 is now up to UC5. There may be a bug that I am not aware of which an update will fix. Page faults are an odd symptom and I am clutching at straws myself here.