Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

Install Oracle Version 10.2.0.1.0 on HP UX 11.31 using Xstart

Fandi Kurnia
Frequent Advisor

Install Oracle Version 10.2.0.1.0 on HP UX 11.31 using Xstart

Hello, all expert.

I have problem when install Oracle Ver. 10.2.0.1. using Xstart. I have some clue that can make you clear with my problem :

1. my oracle user :
# cat /etc/passwd | grep oracle
oracle:x:112:20::/home/oracle:/sbin/sh

2. my oinstall group
# cat /etc/group | grep oinstall
oinstall::107:

3. xclock can appear.

4. Main error :
$ ./runInstaller -ignoresysprereqs
Starting Oracle Universal Installer...

Checking installer requirements...

Checking operating system version: must be B.11.23. Actual B.11.31
Failed <<<<


>>> Ignoring required pre-requisite failures. Continuing...

Preparing to launch Oracle Universal Installer from /tmp/OraInstall2010-02-22_01-36-51PM. Please wait ...$ Oracle Universal Installer, Version 10.2.0.1.0 Production
Copyright (C) 1999, 2005, Oracle. All rights reserved.

java.io.FileNotFoundException: /tmp/OraInstall2010-02-22_01-36-51PM/oui/instImages/images.properties (No such file or directory)
at java.io.FileInputStream.open(Native Method)
at java.io.FileInputStream.(FileInputStream.java:106)
at java.io.FileInputStream.(FileInputStream.java:66)
at oracle.sysman.oii.oiif.oiifm.OiifmSplashScreen.loadProperties(OiifmSplashScreen.java:444)
at oracle.sysman.oii.oiif.oiifm.OiifmSplashScreen.(OiifmSplashScreen.java:93)
at oracle.sysman.oii.oiif.oiifm.OiifmGraphicInterfaceManager.(OiifmGraphicInterfaceManager.java:259)
at oracle.sysman.oii.oiic.OiicSessionInterfaceManager.createInterfaceManager(OiicSessionInterfaceManager.java:193)
at oracle.sysman.oii.oiic.OiicSessionInterfaceManager.getInterfaceManager(OiicSessionInterfaceManager.java:202)
at oracle.sysman.oii.oiic.OiicInstaller.getInterfaceManager(OiicInstaller.java:436)
at oracle.sysman.oii.oiic.OiicInstaller.runInstaller(OiicInstaller.java:926)
at oracle.sysman.oii.oiic.OiicInstaller.main(OiicInstaller.java:866)
Exception java.lang.ExceptionInInitializerError occurred..
java.lang.ExceptionInInitializerError
at oracle.sysman.oii.oiif.oiifm.OiifmGraphicInterfaceManager.(OiifmGraphicInterfaceManager.java:259)
at oracle.sysman.oii.oiic.OiicSessionInterfaceManager.createInterfaceManager(OiicSessionInterfaceManager.java:193)
at oracle.sysman.oii.oiic.OiicSessionInterfaceManager.getInterfaceManager(OiicSessionInterfaceManager.java:202)
at oracle.sysman.oii.oiic.OiicInstaller.getInterfaceManager(OiicInstaller.java:436)
at oracle.sysman.oii.oiic.OiicInstaller.runInstaller(OiicInstaller.java:926)
at oracle.sysman.oii.oiic.OiicInstaller.main(OiicInstaller.java:866)
Caused by: java.lang.NumberFormatException: null
at java.lang.Integer.parseInt(Integer.java:436)
at java.lang.Integer.(Integer.java:609)
at oracle.sysman.oii.oiif.oiifm.OiifmSplashScreen.(OiifmSplashScreen.java:103)
... 6 more
Exception in thread "main" java.lang.NoClassDefFoundError
at oracle.sysman.oii.oiif.oiifm.OiifmGraphicInterfaceManager.(OiifmGraphicInterfaceManager.java:259)
at oracle.sysman.oii.oiic.OiicSessionInterfaceManager.createInterfaceManager(OiicSessionInterfaceManager.java:193)
at oracle.sysman.oii.oiic.OiicSessionInterfaceManager.getInterfaceManager(OiicSessionInterfaceManager.java:202)
at oracle.sysman.oii.oiif.oiifm.OiifmAlert.(OiifmAlert.java:151)
at oracle.sysman.oii.oiic.OiicInstaller.runInstaller(OiicInstaller.java:984)
at oracle.sysman.oii.oiic.OiicInstaller.main(OiicInstaller.java:866)


after problem no.4, there is nothing happen.


Regards

Fandi Kurnia
22 REPLIES
Fandi Kurnia
Frequent Advisor

Re: Install Oracle Version 10.2.0.1.0 on HP UX 11.31 using Xstart

additional clue:
5. JAVA_HOME

$ echo $JAVA_HOME
/opt/java1.4/bin


Horia Chirculescu
Honored Contributor

Re: Install Oracle Version 10.2.0.1.0 on HP UX 11.31 using Xstart

>Checking installer requirements...

Checking operating system version: must be B.11.23. Actual B.11.31
Failed <<<<

You choosed to ignore this (-ignoresysprereqs).

But this is a problem. You have an actual operating system (11.31) and try to install an old database version. Try to install a newer version.

Horia.
Best regards from Romania,
Horia.
Fandi Kurnia
Frequent Advisor

Re: Install Oracle Version 10.2.0.1.0 on HP UX 11.31 using Xstart

hai , see you again horia.

I had done this :
$./runInstaller -ignoresysprereqs

under point number 4.


so what the conclusion for this case horia.. have you ever get this
Horia Chirculescu
Honored Contributor

Re: Install Oracle Version 10.2.0.1.0 on HP UX 11.31 using Xstart

Hello Fandi,

As I said on the previous post, try to install a newer ORACLE version.

Oracle actually maintain a document called "Compatibility matrix". Check this document (I believe you can find it on Metalink) in order to see if a solution would work or not.

Horia.
Best regards from Romania,
Horia.
Duncan Edmonstone
Honored Contributor

Re: Install Oracle Version 10.2.0.1.0 on HP UX 11.31 using Xstart

Hoira,

if you went and looked at that matrix you are referring to in metalink it would tell you that the version _is_ supported and trhat you need to use the "-ignoresysprereqs" option during the install...

Fandi,

How much space do you have in /tmp? Have you made sure you have enough?

HTH

Duncan

HTH

Duncan
Horia Chirculescu
Honored Contributor

Re: Install Oracle Version 10.2.0.1.0 on HP UX 11.31 using Xstart

Duncan, mea culpa: I did not took that look.

Horia.
Best regards from Romania,
Horia.
Duncan Edmonstone
Honored Contributor

Re: Install Oracle Version 10.2.0.1.0 on HP UX 11.31 using Xstart

also where did the oracle sw come from - when this error occurs on the first file ( images.properties ) its usually a sign of a corrupt install distribution...

HTH

Duncan

HTH

Duncan
Fandi Kurnia
Frequent Advisor

Re: Install Oracle Version 10.2.0.1.0 on HP UX 11.31 using Xstart

Hai Duncan, and Horia.
this my configuration ..
$ bdf
Filesystem kbytes used avail %used Mounted on
/dev/vg00/lvol3 27656192 5682784 21801808 21% /
/dev/vg00/lvol1 2048000 189160 1844408 9% /stand
/dev/vg00/lvol7 8192000 660272 7472920 8% /var
/dev/vg00/lvol6 10240000 2597096 7583264 26% /usr
/dev/vg00/lvol5 524288 21984 498896 4% /tmp
/dev/vg00/lvol4 1032192 21712 1002640 2% /home
/dev/vg01/lvol1 143339520 2575136 139664728 2% /database
DevFS 3 3 0 100% /dev/deviceFileSystem

horia,
thank horia. I had read.
WayneHP
Frequent Advisor

Re: Install Oracle Version 10.2.0.1.0 on HP UX 11.31 using Xstart

I seem to recall having to patch the oracle installer first with this version of oracle.

10.2.0.1.

Fandi Kurnia
Frequent Advisor

Re: Install Oracle Version 10.2.0.1.0 on HP UX 11.31 using Xstart

I get some patches but got some trouble when install

ERROR: "cardpro:/tmp/patches/PHKL_35900": An I/O error occurred
while performing this task.
* Source connection failed for
"cardpro:/tmp/patches/PHKL_35900".


# pwd
/tmp/patches
# ll
total 16944
-rw-r----- 1 root users 642080 Feb 23 09:24 PHKL_35900
-rw-r--r-- 1 root users 450560 Feb 21 2007 PHKL_35900.depot
-rw-r--r-- 1 root users 5254 Mar 20 2007 PHKL_35900.text
Horia Chirculescu
Honored Contributor

Re: Install Oracle Version 10.2.0.1.0 on HP UX 11.31 using Xstart

How did you installed the patch?

You should run

swinstall -x autoreboot=true -x patch_match_target=true -s /tmp/patches/PHKL_35900.depot

Horia.

Best regards from Romania,
Horia.
Fandi Kurnia
Frequent Advisor

Re: Install Oracle Version 10.2.0.1.0 on HP UX 11.31 using Xstart

Hi,

After I Execute command from u .. the messages still cannot continue swinstall task..

match_target=true -s /tmp/patches/PHKL_35900.depot <

======= 02/23/10 17:30:31 TST BEGIN swinstall SESSION
(non-interactive) (jobid=cardpro-0027)

* Session started for user "root@cardpro".

* Beginning Selection
* Target connection succeeded for "cardpro:/".
NOTE: The patch match operation did not select patches for software
on target host "cardpro". Patches in the source depot might
already be on the target, or might be superseded by patches on
the target, or might not apply to software on the target.
NOTE: Cannot continue the "swinstall" task.

======= 02/23/10 17:30:32 TST END swinstall SESSION (non-interactive)
(jobid=cardpro-0027)


but the patch still not installed on my hp ux 11.31..
Horia Chirculescu
Honored Contributor

Re: Install Oracle Version 10.2.0.1.0 on HP UX 11.31 using Xstart

>Patches in the source depot might
already be on the target, or might be superseded by patches on
the target, or might not apply to software on the target

It means that you already have the patch installed (or another patch that supersedes this patch)

Horia.
Best regards from Romania,
Horia.

Re: Install Oracle Version 10.2.0.1.0 on HP UX 11.31 using Xstart

Fandi,

I just installed 10.2.0.1 on an Itanium machine. I only had to use the runInstaller -ignoreSysPrereqs (note that the parameter is case sensitive). My install binaries were the latest from Oracle. You need 400MB of free space in /tmp.

I created to directories Disk1 and Disk2 when I unzip the install media, but I found a note saying to create only one directory for both zipped images. Maybe worth a try.

Your missing files, so make sure you have enough free disk space and you have a clean set of install binaires.
Fandi Kurnia
Frequent Advisor

Re: Install Oracle Version 10.2.0.1.0 on HP UX 11.31 using Xstart

well, I still can not take the point of you, I've done the following command:

# swlist-l product | grep PHKL_35900
#

but no clue that says that the patches are already installed. even if I do pencaringan with command

# swlist-l product | more
I do not find these patches are installed properly on HP UX.

I run the installation by using the user oracle "Fandi" as root, not in the oracle user. Then I run

# su - oralce
$. / runInstaller-ignoreSysPrereqs

I think I made a mistake not login as user oracle.

Because if I run SSH Xstart using oracle user it will perform a permissions error and I do not understand, or at the time Xstart can not display X windows I wanted.

However, I will keep trying to solve this problem. thank you for the friend who had given the experience that the oracle 10g can be installed on HP UX 11:31.

I am a beginner in the HP-UX, and this is my first assignment.

Re: Install Oracle Version 10.2.0.1.0 on HP UX 11.31 using Xstart

Fandi,
When you get 10.2.0.1 installed, you need to patch to 10.2.0.4. You should then look at installing the Patch Set Update (10.2.0.4.3), this will require you to update opatch. We are using Exceed to connect to the servers.
Fandi Kurnia
Frequent Advisor

Re: Install Oracle Version 10.2.0.1.0 on HP UX 11.31 using Xstart

thank john..

but oracle 10.2.0.1 or later. didn't installed on my HP UX. I have trouble in first installation.

I cannot using GUI for installation oracle.

Steven E. Protter
Exalted Contributor

Re: Install Oracle Version 10.2.0.1.0 on HP UX 11.31 using Xstart

Shalom Fandi,

Checking operating system version: must be B.11.23. Actual B.11.31
Failed <<<<

Apparently this release of Oracle is not certified on HP-UX 11.31. There is no way around that. You need either the correct OS or a certified version of Oracle. Check http://metalink.oracle.com

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com

Re: Install Oracle Version 10.2.0.1.0 on HP UX 11.31 using Xstart

I have 10g running on HP-UX 10.31 for Itanium. I found this note:
The Deployment Procedure checks for the Operating System version in the prereqs step and displays the following error:

Checking operating system version: must be B.11.23. Actual B.11.31

The 10.2.0.1 shiphome does not support the 11.31 Operating System version for HP. It only supports versions 11.11 and 11.23. Since the platform is certified post production, the user can ignore the step and continue.

(Bug 7109865)


So I am leaning to /tmp being out of space.

java.io.FileNotFoundException: /tmp/OraInstall2010-02-22_01-36-51PM/oui/instImages/images.properties (No such file or directory)

You can set the TMP or TMPDIR to a any directory that contains more disk free space. Make sure all the old install direcories in /tmp are removed.
Horia Chirculescu
Honored Contributor

Re: Install Oracle Version 10.2.0.1.0 on HP UX 11.31 using Xstart

>well, I still can not take the point of you, I've done the following command:

# swlist-l product | grep PHKL_35900
#

>but no clue that says that the patches are already installed. even if I do pencaringan with command

According to :

http://www11.itrc.hp.com/service/patch/patchDetail.do?patchid=PHKL_40130&sel={hpux:11.31,}&BC=main|search|

The cumulative patch PHKL_40130 superseeds the PHKL_35900 patch

Maybe this is the reason.

Horia.
Best regards from Romania,
Horia.
Duncan Edmonstone
Honored Contributor

Re: Install Oracle Version 10.2.0.1.0 on HP UX 11.31 using Xstart

SEP,

>Apparently this release of Oracle is not
>certified on HP-UX 11.31. There is no way
>around that. You need either the correct OS
>or a certified version of Oracle. Check
>http://metalink.oracle.com

Read the rest of the post... Oracle 10gR2 _is_ certified on 11.31, its just that Oracle don't change their installers after a new OS is released, so as it doesn't recognise 11.31 it complains - hence the instruction to use " -ignoresysprereqs".

Fandi,

Why are you obsessing over this patch? Whether you need it or not to _run_ Oracle, you certainly don't need it to _install_ Oracle. As already indicated I think your problem is lack of space in /tmp or a corrupt install media.

HTH

Duncan


HTH

Duncan
Fandi Kurnia
Frequent Advisor

Re: Install Oracle Version 10.2.0.1.0 on HP UX 11.31 using Xstart

thanks all, for all assistance, now I using HP UX 11.23. I still learning about HP UX 11.31