Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

Ioctl ASYNC_CONFIG error, errno = 1

Ahmad Munawwar
Frequent Advisor

Ioctl ASYNC_CONFIG error, errno = 1

Hi,

I got the following error in my oracle trace file as follow:

*************************************
Server # 937 --> pwd

/opt/app/oraclea/rdbms/log

Server # 938 --> cat ora_10179.trc

/opt/app/oraclea/rdbms/log/ora_10179.trc

Oracle8 Enterprise Edition Release 8.0.6.2.0 - Production

PL/SQL Release 8.0.6.2.0 - Production

ORACLE_HOME = /opt/app/oraclea

System name: HP-UX


Release: B.11.00

Version: A

Machine: 9000/800

Instance name: bmpa

Redo thread mounted by this instance: 0

Oracle process number: 0

Unix process pid: 10179, image: oraclebmpa

Ioctl ASYNC_CONFIG error, errno = 1

****************************************

At first there is no file
/etc/privgroup created and my device file is as follow:

Server # 1759 --> ls -liat | grep async

679 crw-rw-rw- 1 bin bin 101 0x000000 Dec 9 2001 asyncdsk

155 crw-rw-rw- 1 oraclea dbaa 101 0x000000 Mar 3 2000 async



I followed the steps below which i found in the forums.

********************************
To check if a group has the MLOCK privilege, execute:

% /usr/bin/getprivgrp

If the dba group is not listed, then set it:

% /usr/sbin/setprivgrp MLOCK

Note, the next reboot will clear this privilege. To automate this at startup, create /etc/privgroup with the entry dba MLOCK

This can be tested with



% /usr/sbin/setprivgrp -f /etc/privgroup

See 'man 1m setprivgrp' for more information.

*******************************************

Monitored trace log from morning till now.

Result : the trace logs are still been created reflecting the same error.

Please advise if i miss any steps or there is something wrong with my file device.

The only left is "restart the oracle engine".

If the problem is because the oracle has not been restart. Is there any way to get rid of it?.

Regards,
Munawwar
8 REPLIES
T G Manikandan
Honored Contributor

Re: Ioctl ASYNC_CONFIG error, errno = 1

Oracle does not have the memory lock privilege,


provide MLOCK privileges to Oracle owner

# setprivgrp dba MLOCK


To retain the MLOCK privilege after rebooting, create the /etc/privgroup file, if it does not exist on your system, and add the following line to it:

dba MLOCK



Andreas D. Skjervold
Honored Contributor

Re: Ioctl ASYNC_CONFIG error, errno = 1

Hi

I belive this will be resolved when you restart Oracle.
This error is not a major one and don't affect Oracle operations. You'll be able to live with it until you next scheduled shutdown of Oracle.

To restart Oracle ( a rough way):
$ svrmgrl
SVRMGR> connect internal
SVRMGR> startup force

Andreas
Only by ignoring what everyone think is important, can you be aware of what everyone ignores!
T G Manikandan
Honored Contributor

Re: Ioctl ASYNC_CONFIG error, errno = 1

Can you post the output of

/usr/sbin/setprivgrp -f /etc/privgroup

Also do you have all the OS patches recommended by the Oracle for HPUX for the version.

REvert
Ahmad Munawwar
Frequent Advisor

Re: Ioctl ASYNC_CONFIG error, errno = 1

Hi,

We cannot restart oracle engines now. We just down it on saturday for the monthly backup. If the error is not a major error then i will schedule it next month.

Just before that i want to makesure it is not because of something else (configuration).

File /etc/privgroup was created with 444 permissions. is it O.K?

br,
Munawwar

Ahmad Munawwar
Frequent Advisor

Re: Ioctl ASYNC_CONFIG error, errno = 1

Hi,

Which one of these groups should be given the MLOCK privledge?

Group Owner

dbaa bmpdbaa

dba oraclea

bmpa bmpadma

I had already executed the "setprivgrp -f" option and below for the output.

wang04 # 2591 --> /usr/bin/getprivgrp dba

dba: MLOCK

wang04 # 2592 --> cat /etc/privgroup

dba MLOCK

Regards,
Munawar
T G Manikandan
Honored Contributor

Re: Ioctl ASYNC_CONFIG error, errno = 1

Do you have two oracle installations on the machine.Why you are having oraclea and dbaa user and group.

You have the async device file owner and group as oraclea and dbaa.
Then this should be added to the MLOCK privilege.

Add dbaa to the /etc/privgroup for MLOCK privilege.

Revert
Ahmad Munawwar
Frequent Advisor

Re: Ioctl ASYNC_CONFIG error, errno = 1

Hi,

If i want to change/add the entry of /etc/privgroup, do i have to delete the old setting? how? or just run command

% /usr/sbin/setprivgrp dbaa MLOCK

Please advice

br,
munawar
T G Manikandan
Honored Contributor

Re: Ioctl ASYNC_CONFIG error, errno = 1

Yes that should be enough,


# setprivgrp dba MLOCK


To retain the MLOCK privilege after rebooting, create the /etc/privgroup file, if it does not exist on your system, and add the following line to it:

dba MLOCK

But make sure you check it using
#/usr/bin/getprivgrp