Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

Libraries probleme with Oracle

Ali_11
Occasional Advisor

Libraries probleme with Oracle

Hi,

I've just install Oracle 8.1.5 32bits in a HP10.20 with binaries loaded from a tar in a HP11.00 server.
I installed it and when I try to launch svrmgrl or sqlplus , it returns me an error :
/usr/lib/dld.sl: Can't find path for shared library: libm.2
/usr/lib/dld.sl: No such file or directory
Abort

All the PATH ( SHLIB_PATH, LD_LIBRARY_PATH, ORACLE_HOME ) are set correctly.
I tried to relink with relink all , or make but it returns me fatal errors.

Can someone have an idea, please.

thanks.
6 REPLIES
Fred.Wu
Frequent Advisor

Re: Libraries probleme with Oracle

Pls read documents on Oracle website and install all critical patches for hp-ux platform.
fred
Brian Crabtree
Honored Contributor

Re: Libraries probleme with Oracle

What errors do you recieve when you attempt to perform a 'relink all'?

Brian
Ali_11
Occasional Advisor

Re: Libraries probleme with Oracle

I have errors like this for all relink :

/opt/oracle/8.1.5.32/bin/genclntsh
ld: Can't find library for -l:librt.sl
cut: Cannot open /tmp/tempmakes.
rm: /tmp/tempmakes non-existent
find: cannot stat bin
cat: Cannot open /tmp/precompfiles: No such file or directory
(Bundled) cc: warning 480: The +O2 option is available only with the C/ANSI C product; ignored.
/usr/ccs/bin/ld: Can't find library for -l:librt.sl
*** Error exit code 1

Brian Crabtree
Honored Contributor

Re: Libraries probleme with Oracle

Do you know if the ORACLE_HOME used from the tar is the same one you are using? Can you do the following. Go to ORACLE_HOME/rdbms/lib and run:

make -f ins_rdbms.mk ioracle

This will most likely fail, however if you can load all of the text from the failure and put it as an attachment on here, I will see if it might have more information.

Overall, copying Oracle binaries can be done, but it is best to install Oracle from the original installation materials over installation from a tar ball.

Thanks,

Brian
Volker Borowski
Honored Contributor

Re: Libraries probleme with Oracle

Hi,

as far as I remember, there are diffrent executables from Oracle for
HP-UX 10.20
Hp-UX 11.00 32-bit
HP-UX 11.00 64 bit

I think you need to install the correct executables for 10.20. Your 11.0 Exec will not run on 10.20.

Hope this helps
Volker
Ken Hubnik_2
Honored Contributor

Re: Libraries probleme with Oracle

I agree with volker you cannot use the binaries from from 11.00 on 10.20.