Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

Listener problems on Oracle 9.0.2 on HP ux 11i

Chartier Jerome
Frequent Advisor

Listener problems on Oracle 9.0.2 on HP ux 11i

Hi all,


I've got a problem on a database, when I launch too many network sessions, I've got this error message:
ORA-12500:
How can I increase the number of network simultaneous connectionsn permitted ?

Thanks in advance for your help

Regards

J??r??me
J@Y
7 REPLIES
T G Manikandan
Honored Contributor

Re: Listener problems on Oracle 9.0.2 on HP ux 11i

What permissions you have for oracle executable?

Just check this document attached
Yogeeraj_1
Honored Contributor

Re: Listener problems on Oracle 9.0.2 on HP ux 11i

hi J??r??me,

===============================================
oerr ora 12500
12500, 00000, "TNS:listener failed to start a dedicated server process"
// *Cause: The process of starting up a dedicated server process failed.
// The executable could not be found or the environment may be set up
// incorrectly.
// *Action: Turn on tracing at the ADMIN level and reexecute the operation.
// Verify that the ORACLE Server executable is present and has execute
// permissions enabled. Ensure that the ORACLE environment is specified
// correctly in LISTENER.ORA. The Oracle Protocol Adapter that is being
// called may not be installed on the local hard drive. Please check that
// the correct Protocol Adapter are successfully linked.
// If error persists, contact Oracle Customer Support.
===============================================

Odds are -- if you are GETTING an ora-12500 it means your system is way over taxed.

The ORA-12500 -- could be caused by hitting the listener too fast, faster then the OPERATING system itself can deal with. If you are using dedicated server configurations for example, each connection is a unix fork/exec.
If you overload the OS, it won't be able to spawn any new processes. Its not really that you hit the LISTENER too fast in this case, more that the OS is physically out of resources or is taking so long to get these resources in place that we time out. How fast is too fast -- thats a function of your OS, the amount of ram, how many cpu's you have, how fast they are, what else is going on
on the box, etc etc etc...

Do you have processes set correctly? Have you poked about in the logs to see what the underlying issue is exactly?

regards
Yogeeraj
No person was ever honoured for what he received. Honour has been the reward for what he gave (clavin coolidge)
Chartier Jerome
Frequent Advisor

Re: Listener problems on Oracle 9.0.2 on HP ux 11i

Hi,

The server is a 2x650MHz, 4 GB of RAM, I've increased the swap to 4GB, but it is still using a lot of RAM:

swapinfo
Kb Kb Kb PCT START/ Kb
TYPE AVAIL USED FREE USED LIMIT RESERVE PRI NAME
dev 4194304 29360 4164944 1% 0 - 1 /dev/vg00/lvol2
dev 4194304 0 4194304 0% 0 - 1 /dev/vg00/lswap2
reserve - 2553408 -2553408
memory 3165420 2495728 669692 79%

I certainly need to change kernel + orainit parameters ...

Could you help

Thanks in advance

Regards

J??r??me
J@Y
Mark Grant
Honored Contributor

Re: Listener problems on Oracle 9.0.2 on HP ux 11i

Jerome,

As it seems that there could be many reasons for the error you are getting, have you checked syslog.log to see if there is any more specific information. You don't really want to increase things unless you really need to.

Regards
Never preceed any demonstration with anything more predictive than "watch this"
T G Manikandan
Honored Contributor

Re: Listener problems on Oracle 9.0.2 on HP ux 11i

I would first view the

processes parameter in the init.ora file.

If that parameter is high enough then I would look into the kernel parameters

maxuprc-->maximum number of user processes

Please revert on the same
Chartier Jerome
Frequent Advisor

Re: Listener problems on Oracle 9.0.2 on HP ux 11i

Hi,

Here is the init.ora file, and the maxuprc is 75, then the shmmax 1073741824 ..

Thanks for your help

Regards

Jerome

J@Y
R. Allan Hicks
Trusted Contributor

Re: Listener problems on Oracle 9.0.2 on HP ux 11i

I believe if you check the release notes, you'll find that your maxuprc is way too low.

nproc should be 4096
maxuprc should be ((NPROC*9)/10)

I recommend that you scour the release notes for kernel parameters. They are _very_ important.

-good luck
"Only he who attempts the absurd is capable of achieving the impossible