cancel
Showing results for 
Search instead for 
Did you mean: 

NIS and Informix

Mike Stewart
Occasional Contributor

NIS and Informix

I am having a very strange password change problem with NIS and Informix. When a user changes their password on a server that is a NIS client, they cannot connect to Informix using the new password immediately. It seems to take about 1 to 2 minutes for Informix to recognize it. However they are able to telnet in to the server using the changed password and it works right away! We are running HPUX 11.11 and Dynamic Server 10.
Any help would be appreciated.

Mike Stewart
Mike Stewart
3 REPLIES
Peter Godron
Honored Contributor

Re: NIS and Informix

Mike,
what error message are you getting from Informix? Is it 952?
Mike Stewart
Occasional Contributor

Re: NIS and Informix

Yes it is error 952. I called Informix tech support yesterday and they claim they do nothing special with checking passwords. They of course blame the operating system.

I can understand a small delay with NIS updating the map files, but I do not understand why telnet seems to recognize the new password right away.
Mike Stewart
A. Clay Stephenson
Acclaimed Contributor

Re: NIS and Informix

One of the possible differences between a telnet connection and a database connection is that there is always a new telnetd process for every connection but depending upon your connection method there may not be a new process spawned on the server end. A long shot would be to kill the passwd/group caching daemon.

cd /sbin/init.d
./pwgr stop

UNIX boxes ran for decades w/o this daemon and your box will too so if that fixes the problem, you can simply disable the daemon.
If it ain't broke, I can fix that.