Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

OB2 3.1 to 3.5 migration Oracle 8.16 integration question

Dan Ryan
Advisor

OB2 3.1 to 3.5 migration Oracle 8.16 integration question

Hello eveyone,

Have any of you folks done an OB2 3.1 to 3.5 upgrade on a system as follows?:

We have HP-UX 11.0 with OB2 3.1 and Oracle 8.16. Using RMAN for Hot & Cold Backups. We'll be moving to OB2 3.5. the Oracle binary is linked as follows:
oracle:
shared executable
shared library dynamic path search:
SHLIB_PATH enabled first
embedded path disabled second Not Defined
shared library list:
dynamic /oracle/app/oracle/product/8.1.6/lib//libwtc8.sl
dynamic /oracle/app/oracle/product/8.1.6/lib//libjox8.sl
static /opt/omni/lib/libob2oracle8.sl
dynamic /usr/lib/librt.2
dynamic /usr/lib/libpthread.1
dynamic /usr/lib/libnss_dns.1
dynamic /usr/lib/libdld.2
dynamic /usr/lib/libm.2
dynamic /usr/lib/libc.2
shared library binding:
deferred

OB2 3.1 has the following share library ll /opt/omni/lib | grep ora
-r-xr-xr-x 1 root sys 1264243 Aug 23 1999 libob2oracle8.sl
-r-xr-xr-x 1 root sys 821392 Aug 23 1999 libob2oracle8_64bit.sl

OB2 3.5 has the following share library
-r-xr-xr-x 1 root sys 11317077264243 Apr 19 2000 libob2oracle8.sl

The OB2 Upgrade doc doesn't mention having to relink Oracle as part of the OB2 3.1 to 3.5 upgrade, but it looks to me to we should.

Thanks in advance for your input.






Don't have time to do it right the first time, but always time to do it twice
2 REPLIES
Chris B
Occasional Advisor

Re: OB2 3.1 to 3.5 migration Oracle 8.16 integration question

We did similar upgrade but not same, for OBII from 3.1 to 3.5 with Oracle 8.0.6
We did re-linked libraries, and now working okay.
I think re-linking library should not creat new problem.
I hope this may help you.
thanks.
Chance happens to all but turn it to account is gift of few.
Chris B
Occasional Advisor

Re: OB2 3.1 to 3.5 migration Oracle 8.16 integration question

We did similar upgrade but not same, for OBII from 3.1 to 3.5 with Oracle 8.0.6
We did re-linked libraries, and now working okay.
I think re-linking library should not creat new problem.
I hope this may help you.
thanks.
Chance happens to all but turn it to account is gift of few.