Simpler Navigation coming for Servers and Operating Systems
Coming soon: a much simpler Servers and Operating Systems section of the Community. We will combine many of the older boards, and you won't have to click through so many levels to get at the information you need. If you are looking for an older board and do not find it, check the consolidated boards, as the posts are still there.
Showing results for 
Search instead for 
Did you mean: 

ORA-00018 and ORA-00604


ORA-00018 and ORA-00604

Deal all,
My system occur a error message( ORA-00018 and ORA_00604)
I find the reslove method as fllow:
"Action: Try the operation again in a few minutes. If this message occurs often, shut down Oracle, increase the SESSIONS parameter in the initialization parameter file, and restart Oracle "

Question is:
Should I to modify the init.ora that enlarge the process number from 50 to 200 ???
Service is King
T G Manikandan
Honored Contributor

Re: ORA-00018 and ORA-00604


You need to increase the value of the SESSIONS parameter in the init.ora file.
Increase the value of PROCESSES since SESSIONS is derived off of the PROCESSES parameter.


Then re-started the database to re-read the initSID.ora file to make changes take effect
T G Manikandan
Honored Contributor

Re: ORA-00018 and ORA-00604


There is another feature in this forums of assigning points to the answers.

Just check this|*?Page=file0002

Re: ORA-00018 and ORA-00604

Help !!!
When I try to modify the init.ora which change the process number to 150..
Shutdown Oracle, and Try to
restart Oracle....
It fail....
Give me error message...
HP:28 No space left on device.
I check the filesystem Usage.
It is normal...Why???

Thanks. and Regards.
Service is King
T G Manikandan
Honored Contributor

Re: ORA-00018 and ORA-00604

You have tried to increase the parameter processes in the initsid.ora file.

Then the problem is it is running out of semaphores.
You need to increase the value of SEMMNS in the kernel.
Normally,this value is configured for oracle instance as
processes * 2 => semmns value

calculate if you are running more oracle instances accordingly.

Set your Semmns value to the double the value of the processes value configured in the instance.

You can do this in SAM

SAM---->kernel configuration--->parameters

change SEMMNS

Re-build the new kernel and reboot the system.

That should solve this error.