Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

ORA-01034: ORACLE not available

SOLVED
Go to solution
HPADM
Advisor

ORA-01034: ORACLE not available

Hi,
I installed oracle. When I do sqlplus and I try to connect as system I get:

ERROR:
ORA-01034: ORACLE not available
ORA-27101: shared memory realm does not exist
HP-UX Error: 2: No such file or directory

What's the problem?
7 REPLIES
Andreas D. Skjervold
Honored Contributor

Re: ORA-01034: ORACLE not available

Hi

Could be a couple of things:
First, have you successfully created a database and is it started? Do a 'ps -ef |grep pmon' and check if you have a ora_pmon_ process.

If you have, is your enviroment set up with correct ORACLE_SID?
export ORACLE_SID=

rgds
Andreas
Only by ignoring what everyone think is important, can you be aware of what everyone ignores!
HPADM
Advisor

Re: ORA-01034: ORACLE not available

No I wasn't successfull to create the database after the installation with the oracle GUI because of ERROR:
ORA-01034: ORACLE not available
G. Vrijhoeven
Honored Contributor

Re: ORA-01034: ORACLE not available

Hi,

I am no oracle specialist but can it be so that you need to start a listener to connect to a database?

# su - oracle -c "lsnrctl start"


Gideon
Andreas D. Skjervold
Honored Contributor

Re: ORA-01034: ORACLE not available

If your installatin failed at the db createion part, you'll need to create the database manually (this is always the preferred way)

From one of my erlier postings:

The easy way out is this:
Run the dbca assistant. This is a Java wizard that lets you set up the database whitout createing the scripts yourself.
To run:
export DISPLAY=yourworkstation:0.0
cd $ORACLE_HOME/bin/
./dbca

Fill in all the windows and the dbca can create the database for you.

BUT
what you should do is to select "Create script" in the last window.
This saves the create scripts for the database in a given location.

You can the edit and run these scripts one by one to have full controll over your database (as you should)

If one script fails, you just correct the error and start over until you have it right.


Andreas

Only by ignoring what everyone think is important, can you be aware of what everyone ignores!
Volker Borowski
Honored Contributor

Re: ORA-01034: ORACLE not available

Hi,

to connect as "system" you need to have a running and open database, because "system" is a database user.

If you have no database yet, you have to go by

connect internal
or
connect ... as sysdba

Then you can
- startup nomount
- create a database
- apply catalog.sql / catprog.sql
- connect system/manager

Hope this helps
Volker

Bill Thorsteinson
Honored Contributor
Solution

Re: ORA-01034: ORACLE not available

The attached scripts will setup the environment and install a database. It takes a few minutes on our development machine. It should work with most recent versions of ORACLE.

mkcfg.sh: will create the configuration directories and files for a database. Edit definition of ORACLE_HOME here if necessary. Edit or compatibility options for versions other than 8.1.7.

TEST8i: is the configuration for a test database. It contains all the parameters except ORACLE_HOME

create8i.sh: will create a database and is designed for oracle 8i.

destroydb.sh: will destroy a test database.

Assumes:
Oracle is installed in /u1/oracle/product/8.1.7
The mount points /u2, /u3, /u4, /u5, and /u99 exist.

Satish_12
Occasional Visitor

Re: ORA-01034: ORACLE not available

See if ORACLE_SID is set, check this by typing echo $ORACLE_SID.
if ORACLE_SID is not set then set it.