Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

ORACLE_HOME_NAME default settings for Oracle 9206 patchset

Michele (Mike) Alberton
Regular Advisor

ORACLE_HOME_NAME default settings for Oracle 9206 patchset

Hi,

we were installing 9206 on top of 9201 as part of a standard upgrade we already ran on many systems (HP-UX 11.11).

We were not specifying ORACLE_HOME_NAME in the response command for the silent installer and most of the time we got in the installAction log file:

Setting the 'OracleHomeName ( ORACLE_HOME_NAME )' property t
o 'OHOME920'. Received the value from the default settings.

But sometime the silent installation failed because of:

Error:Values for the following variables could not be obtained from the command line or response fil
e(s):
ORACLE_HOME_NAME(OracleHomeName)
Silent install cannot continue.


Now my question is, where are the "default settings" configured ?

We could verify that before keep going with the installation, and eventually add the item to the response file.

Thanks !

Mike
6 REPLIES
Yogeeraj_1
Honored Contributor

Re: ORACLE_HOME_NAME default settings for Oracle 9206 patchset

hi mike,

this is related to a bug!

For 10g, you would have to do:

1. Start OUI 10.1.0.3 with this command:

./runInstaller -record -destinationFile /tmp/recorded.rsp

2. Make all the selections you want to (source destination, home, home name, products....)

3. When you get to the "Summary" screen, instead of clicking on "Install" click on "Cancel"

4. Now perform the silent installation like this:

./runInstaller -silent -responseFile /tmp/recorded.rsp

For 9i, try the following workarounds:
Workaround 1
============
The following workaround can be used in some situations:

1. Modify the response file by changing
RESPONSEFILE_VERSION=2.2.1.0.0
to
RESPONSEFILE_VERSION=1.7.0

2. Rerun the silent install

Workaround 2
============
1. Comment out or remove the following three section headers from the supplied response file:
[General]
[SESSION]
[oracle.rdbms_9.2.0.7.0]

2. Rerun the silent install


hope these helps!

kind regards
yogeeraj
No person was ever honoured for what he received. Honour has been the reward for what he gave (clavin coolidge)
Yogeeraj_1
Honored Contributor

Re: ORACLE_HOME_NAME default settings for Oracle 9206 patchset

hi again,

i would suggest that you try the 10g solution which looks more neat!

kind regards
yogeeraj
No person was ever honoured for what he received. Honour has been the reward for what he gave (clavin coolidge)
Michele (Mike) Alberton
Regular Advisor

Re: ORACLE_HOME_NAME default settings for Oracle 9206 patchset

Hi Yogeeraj !

Sorry maybe I did not explain myself fine.
We have a response file but we don't specify the ORACLE_HOME_NAME variable there, the rest being specified as per our needs.

When the installer tells me that it gets that value out of "default settings" what does it mean exactly ?

Is there any way to get a list of existing default settings values ?

Thanks a lot for the quickness.


Cheers,

Mike
Yogeeraj_1
Honored Contributor

Re: ORACLE_HOME_NAME default settings for Oracle 9206 patchset

hi mike,

sorry for the confusion, it is an erronous message because of a bug!

i believe default settings it could be from the environment variable defined (ORACLE_HOME)


please check

kind regards
yogeeraj


No person was ever honoured for what he received. Honour has been the reward for what he gave (clavin coolidge)
Michele (Mike) Alberton
Regular Advisor

Re: ORACLE_HOME_NAME default settings for Oracle 9206 patchset

Hi !

Thanks a lot, now it makes more sense to me :-)

By the way do you have any reference to this bug ? We'll have to explain to our Customer the reason for different behaviours, so that it would come in handy.

I appreciated !

Mike
Michele (Mike) Alberton
Regular Advisor

Re: ORACLE_HOME_NAME default settings for Oracle 9206 patchset

Hi,

since we ware dealing with a Service Guarded system with Oracle binaries mounted on a Package owned file system the issue was with

/var/opt/oracle/oraInst.loc

not being available on both nodes.

We'll check this during the next isntallation, and in case use your suggestions to move on.

Thanks a lot for the quickness !

Cheers,

Mike