Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

Oracle 10g, cant run dbca,emca on HP UX, JAVA ERROR

Oracle 10g, cant run dbca,emca on HP UX, JAVA ERROR

Hi All,

I am Darshan,

While running dbca,emca on HP UX I am getting following error, Pls help me to remove this error.

java.lang.unsatisfiedlinkError: no OSUtils in java.library.path.

2)While installing Oracle10g, do I have to install jdk1.4 separately on HP-UNIX OR Oracle does it itself?????

looking for a solution, I have been stuck up since last week.

Regards,

Darshan
2 REPLIES
Patti Johnson
Respected Contributor

Re: Oracle 10g, cant run dbca,emca on HP UX, JAVA ERROR

The following work around was given for this issue on Metalink (but for AIX). It might give you a clue.
From note 274397.1

Cause
SHLIB_PATH is not set in the emca script. It is not sufficient to set the SHLIB_PATH variable at the environment.
Fix
1. Open the $ORACLE_HOME/bin/emca script and find the line:
"export LD_LIBRARY_PATH"
2. Add the following lines to the script file after the line listed above:
SHLIB_PATH="${LD_LIBRARY_PATH}"
export SHLIB_PATH
3. Save the file
Jean-Luc Oudart
Honored Contributor

Re: Oracle 10g, cant run dbca,emca on HP UX, JAVA ERROR

Darshan

found similar issue but with oracle 9i. You may well check this Metalink document :
Note:292412.1 "New Database creation using DBCA Getting Java.Lang.Unsatisfiedlinkerror"

to summarise there some missing files , therefore you can find the files (and copy them) from install dir or nuild the database manully.

Regards
Jean-Luc
fiat lux