Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

Oracle 9i runInstaller problem

SLIMANI_1
Occasional Advisor

Oracle 9i runInstaller problem

Hi,
trying to install oracle 9202 on HP-UX 11i , and when executing ". ./runInstaller" i am getting the error "ksh: LD_LIBRARY_PATH: parameter not set"
the variable is defined in .profile file , but the script itself unset it then show the error "ksh: LD_LIBRARY_PATH: parameter not set"

I ve tried the comment the unset command from runInstaller i am getting "ksh: *: parameter not set" error

any help will be appreciated
thinks
12 REPLIES
Yogeeraj_1
Honored Contributor

Re: Oracle 9i runInstaller problem

hi,

did you run the install_prep script prior to the installation? (this script which is available from metalink, can help you in configuring your environment before the installation)

can you try to specify the full path for the runInstaller program instead?
e.g. /SD_CDROM/db/Disk1/runInstaller*

hope this helps!
regards
yogeeraj
No person was ever honoured for what he received. Honour has been the reward for what he gave (clavin coolidge)
SLIMANI_1
Occasional Advisor

Re: Oracle 9i runInstaller problem

I ve run the installPrep script, all is Ok
I ve also run the runInstaller using the full path , same problem.
Yogeeraj_1
Honored Contributor

Re: Oracle 9i runInstaller problem

hi again,

in our installation environment, we only had the following environment variables set:

export LD_LIBRARY_PATH ORACLE_HOME ORACLE_SID PATH TMP TMPDIR TNS_ADMIN

can you check the value in the LD_LIBRARY_PATH prior to the installation? is it ok?

regards
yogeeraj
No person was ever honoured for what he received. Honour has been the reward for what he gave (clavin coolidge)
SLIMANI_1
Occasional Advisor

Re: Oracle 9i runInstaller problem

I checked the value of LD_LIBRARY_PATH , it s OK
Jean-Luc Oudart
Honored Contributor

Re: Oracle 9i runInstaller problem

Hi

what shell do you use for the "oracle" user ?

Regards
Jean-Luc
fiat lux
Yogeeraj_1
Honored Contributor

Re: Oracle 9i runInstaller problem

hi again,

quite difficult to troubleshoot.

As per the Install Quick Start for 9.2.0, can verify that required environment variables are set accordingly:
ORACLE_TERM - eg, vt100, hpterm
DISPLAY - set this to :0.0
must be set before running Installer
ORACLE_BASE - set this to the top dir of Oracle software structure
eg, /u01/OFA_base/app/oracle
ORACLE_HOME - set to the dir where Oracle software installed
eg, /u01/OFA_base/app/oracle/product/V9.2.0
ORACLE_SID - set to the SID of the database
SHLIB_PATH - required for oracle products using shared libraries
must include $ORACLE_HOME/lib32, /usr/lib and dir
containing Motif libs
eg, /usr/lib:$ORACLE_HOME/lib32:
/usr/lib:/usr/lib/Motif1.2
LD_LIBRARY_PATH
- as SHLIB_PATH, but for 64 bit executables must include $ORACLE_HOME/lib
PATH - must include $ORACLE_HOME/bin
TMP or TEMP - used by installer to override the default location of /tmp
TMPDIR - used by 'ar' to override default location of /var/tmp
- used by 'ld' to override default location of /var/tmp


regards
yogeeraj
No person was ever honoured for what he received. Honour has been the reward for what he gave (clavin coolidge)
SLIMANI_1
Occasional Advisor

Re: Oracle 9i runInstaller problem

I am using ksh shell for oracle user. and LD_LIBRARY_PATH, ORACLE_HOME, ORACLE_BASE,... are set in .profile file.

I found some thing strange when executing the InstallPrep script : it fount the LD_LIBRARY_PATH, ORACLE_HOME, ORACLE_BASE,... are correctly set as environnement variable but also ask me to add it to .profile .
Yogeeraj_1
Honored Contributor

Re: Oracle 9i runInstaller problem

hi again,

very hard to troubleshoot.

i would suggest that you contact Oracle support or if you have a support contract with Oracle, log an itar on metalink.

good luck

kind regards
yogeeraj
No person was ever honoured for what he received. Honour has been the reward for what he gave (clavin coolidge)
podichin
Advisor

Re: Oracle 9i runInstaller problem

Hi Salmani..,

R u sure urn profile si executing properly?

login to the system as installation user
Try to see any of ur values u set in to ur profile,like

$echo $LD_LIBRARY_PATH
it should return the value what u set..,

If its not returning this valus.., Ur .profile is not executing..,

Try to check the file permission...etc..

Cheers,

Siju
Eric Antunes
Honored Contributor

Re: Oracle 9i runInstaller problem

Hi,

Put this in a script and run it:

if /usr/bin/test $LD_LIBRARY_PATH then
/usr/bin/echo IsSet
else
/usr/bin/echo UnSet
fi

Best Regards,

Eric Antunes
Each and every day is a good day to learn.
Nguyen Anh Tien
Honored Contributor

Re: Oracle 9i runInstaller problem

I think that the LD_LIBRARY_PATH parameter is not set correctly.
Pls check it by
#env|grep LD_LIBRARY_PATH
if this parameter is not display it mean you set increctly. You should set it manually
# export LD_LIBRARY_PATH=/....///
and run
#./runInstaller.
HTH
tienna
HP is simple
SLIMANI_1
Occasional Advisor

Re: Oracle 9i runInstaller problem

The version of the install was not adequate with the server
Thinks all