Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

Oracle Applications install failing with JDK version error..

Stuart Abramson_2
Honored Contributor

Oracle Applications install failing with JDK version error..

We are installing Oracle Applications 11i on hpux 11i.

We are getting the message:

JDK version mismatch:

Your JDK must be version 1.3.

But we DO have JDK version 1.3 (1.3.1.10):

# swlist | grep -i java
B8111AA 1.2.2.14.02 Java 2 RTE for HP-UX (700/800), PA1.1 + PA2.0 Add On
B9098AA 1.2.2.14.02 Java 2 Plugin for HP-UX (700/800)
B9788AA 1.3.1.10.07 Java2 1.3 SDK for HP-UX <<== THIS ONE HERE...
B9789AA 1.3.1.09.05 Java2 1.3 RTE for HP-UX
T1455AA 1.3.1.09.05 Java2 1.3 Netscape Plugin for HP-UX

Does anybody have any experience with this?
5 REPLIES
Massimo Bianchi
Honored Contributor

Re: Oracle Applications install failing with JDK version error..

from command prompt:

which java

Oracle will use the first java machine, so we
must check which one comes first.

echo $PATH

Massimo
Helen French
Honored Contributor

Re: Oracle Applications install failing with JDK version error..

What version of Oracle are you installing? If you think you have the right Java version installed on the system, then do not install Java from Oracle installation pack. This option will be selected by default when you install Oracle, but you can remove that part from the installation menu.

Also, make sure that you have all patches installed before proceeding with the installation.
Life is a promise, fulfill it!
Steven E. Protter
Exalted Contributor

Re: Oracle Applications install failing with JDK version error..

swverify the java installation.

Maybe the 1.3 is corrupt.

Check the java path you put into the Oracle GUI is correct.

SHLIB_PATH and PATH

The user you are using to fire up the install must have almost every aspect of its environment correct for that install to work right.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
G Ravi Shankar
Occasional Visitor

Re: Oracle Applications install failing with JDK version error..

Hi

PL download the HP's Java1.4 & Install it. This solves all the JDK error getting when installaing the Oracle Apps 11i

Regards

Ravi Shankar
Stuart Abramson_2
Honored Contributor

Re: Oracle Applications install failing with JDK version error..

The correct answer to this was that Oracle Applications 11i requires the Java SDK, not the Java RTE.

Our old Oracle Applications worked just fine with RTE, but 11i needed the complete SDK (for some reason that the DBAs didn't know exactly).

So, we just went to HP web site and downloaded the SDK, which is free of charge (I think..), and we were fine.

The install job checks for something that is included in the SDK, but is not part of the RTE.