Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

Oracle DataGuard between hpux 11.11 and 11.23

Oscar Melez
Occasional Contributor

Oracle DataGuard between hpux 11.11 and 11.23

Hi,

Few months ago we upgraded our db to Oracle 10g on hpux 11.11. Our data center will soon be moved to a new hosting center and the new one will be using Oracle10g on 11.23 itanium. In migrating the data, DataGuard will be used between the two sites. We were advised to upgrade to 11.23 first in order for Dataguard to work since the target server is using 11.23. Can anyone comment about this? In my opinion (I'm a unix admin), Dataguard works in the application layer and as long as both are using Oracle10g, data transfer should be fine regardless of 11i versions. I appreciate your feedback or if anyone has experience doing this. Thanks!
5 REPLIES
Steven E. Protter
Exalted Contributor

Re: Oracle DataGuard between hpux 11.11 and 11.23

Shalom,

I can help explain.

Oracle is an application that compiles itself, creating the binaries as part of the installation.

This step uses OS tools and creates different binaires with different capabilities on 11.11 versus 11.23 back end OS. Oracle has a different install set for PA-RISC versus Itanium servers.

Its therefore due to application binary differences not possible or at least not advisable to attempt a dataguard transfer between two systems with a different OS. This is really an Oracle guideline, but it is within my understanding of what Oracle supports and what it does not.

Does this help?

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com

Re: Oracle DataGuard between hpux 11.11 and 11.23

Hi!

In Oracle documentation I see the following two paragraphs:

"All members of a Data Guard configuration must run an Oracle image that is built for the same platform."

"The operating system running on the primary and standby locations must be the same, but the operating system release does not need to be the same."

see:
Oracle Data Guard Concepts and Administration 10g Release 2 (10.2)
2 Getting Started with Data Guard
2.3.1 Hardware and Operating System Requirements

In my understanding, even after upgrade your PA-RISC box to 11.23 you will still have different platforms. However, as far as I know, both HP-UX on PA-RISC and HP-UX on Itanium are big-endian, so at least Oracle should store datafiles and redo logs on these platforms with the same endianness.

Definitely, you should contact Oracle Support.


P.S. You can also use other means to transfer database, including:

1) "Transportable Tablespaces" feature of Oracle 10g

http://www.oracle.com/technology/pub/articles/10gdba/week16_10gdba.html
http://www.dbazine.com/olc/olc-articles/ault5

2) Oracle exp/imp utilities

Re: Oracle DataGuard between hpux 11.11 and 11.23

R.Bruoth
Occasional Visitor

Re: Oracle DataGuard between hpux 11.11 and 11.23

Failover Cluster & Data Guard Support between PA-RISC & Itanium for Oracle databases

http://www.hp-user-society.de/sig/dbi/oracle/hp_oracle_ctc_newsletter_200612.html#Mixed

and Metalink Note:395982.1
Jonathan Fife
Honored Contributor

Re: Oracle DataGuard between hpux 11.11 and 11.23

I see this is an old thread, but the information in it is incorrect (or at least not current). See Metalink note 395982.1.

"Oracle Database 10g Release 2 (and Oracle9i Database beginning with 9.2.0.7) now supports a Data Guard configuration involving a primary database and one or more standby databases in a mix of HP PA-RISC and HP Itanium based servers (HP9000 and HP Integrity servers respectively, and referred to as "mixed-HP architecture" in this note), running HP-UX v11. "
Decay is inherent in all compounded things. Strive on with diligence