cancel
Showing results for 
Search instead for 
Did you mean: 

Oracle error

sreejith_4
Frequent Advisor

Oracle error

Hi,

I am new to oracle .
I am getting the following error while strating up oracle.

% sqlplus "/as sysdba"

SQL*Plus: Release 9.2.0.4.0 - Production on Fri Mar 4 15:56:50 2005

Copyright (c) 1982, 2002, Oracle Corporation. All rights reserved.

Connected to an idle instance.

SQL> startup
ORA-04031: unable to allocate 95400 bytes of shared memory ("shared pool","unknown object","sga heap(1,0)","qmps connections")


Please help,

Thanks
Sreejith M
4 REPLIES
Jean-Luc Oudart
Honored Contributor

Re: Oracle error

Sreejith

In most cases this is either shared pool is too smal or is fragmented.
As this is happening when you start the database, I would look at 1st case.

Is this the 1st time you start this database ?
What are the shared_pool parameters in the init.ora file ?
Available memory on the server ?

Regards
Jean-Luc
fiat lux
sreejith_4
Frequent Advisor

Re: Oracle error

Hi,

I have made the changes in init.ora file , saved it , then run the comand "startup" from sql> prompt.. But same error.

Do i have to do anything else after modifying these parameters

Thanks
Sreejith M
Jean-Luc Oudart
Honored Contributor

Re: Oracle error

Hi,

Has this database started before ? (or is this "never") If yes do you still have the init.ora file to compare with current for differences ?

Regards
Jean-Luc
fiat lux
TwoProc
Honored Contributor

Re: Oracle error

What's the value of the kernel parameter "shmmax" ? run (as root) the following:
kmtune | grep shmmax

This should return a number larger than what you're trying to allocate. If not, it's time to make it larger. This may or may not actually stop you from allocating the memory - but it could cut it up into a lot of chunks.

What's more likely to stop you from getting there at all is maxdsiz - if you're running the 64 bit version of the database you need to review maxdsiz_64bit. You may also need to review the size of maxtsiz and maxtsiz_64bit - but that's less likely - but good to look at anyway.

You can look at all of your "max" type kernel parameters with:
kmtune | grep -i max

HTH
We are the people our parents warned us about --Jimmy Buffett