Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

Perl 5.8.0 and DBD::Oracle 1.12 install on HPUX 11

Raymond Cordoni
Occasional Advisor

Perl 5.8.0 and DBD::Oracle 1.12 install on HPUX 11

I am trying to compile perl 5.8.0 from source on one HPUX 11 server (that has the HP ANSI C compiler) and copy the resulting perl install to another HPUX 11i server (that doesn't have the HP ANSI C compiler). The two HP servers are running different versions of Oracle - my source server is running Oracle 8.0.6 64bit and my target server is running Oracle 9.2.0 64bit. Amazingly, I got all this to work - but I have one problem that I don't know how to resolve. The problem is the DBD::Oracle install creates a shared library called Oracle.sl which is linked to "libclntsh.sl.1.0" instead of "libclntsh.sl". This means that when I copy perl to my target server, I have to copy libclntsh.sl.1.0 (which is Oracle 8.0.6 code) to the 64bit shared library directory of my Oracle 9.2.0 installation. Is there some way to get the make for DBD::Oracle 1.12 to use libclntsh.sl? This way my copying of perl would be independant of the Oracle release on the target machine. I do not know very much about make files, shared libraries, etc. I think the reason that Oracle.sl references libclntsh.sl.1.0 is because the "internal name" for libclntsh.sl is libclntsh.sl.1.0 on my source server. This is the way that the Oracle install creates it - so I don't want to mess with that.

Thanks
Ray Cordoni
2 REPLIES
harry d brown jr
Honored Contributor

Re: Perl 5.8.0 and DBD::Oracle 1.12 install on HPUX 11


go here https://www.beepz.com/personal/merijn/

and check out hot to properly build perl.

live free or die
harry
Live Free or Die
Raymond Cordoni
Occasional Advisor

Re: Perl 5.8.0 and DBD::Oracle 1.12 install on HPUX 11

Thanks Harry for the link. Lots of good information on this site - but it seems to be mostly about building perl using gcc. I didn't see anything about my specific problem.

Ray Cordoni