Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

Perl DBI module install fails HP-UX 11.11

Rick Grubin
Occasional Visitor

Perl DBI module install fails HP-UX 11.11

Can't get Perl DBI module to build/install properly (can't use gcc):

root@ejl144[255] make
/usr/bin/perl -I/opt/perl/lib/5.6.1/PA-RISC1.1-thread-multi -I/opt/perl/lib/5.6.1 -MExtUtils::Command -e mkpath blib/lib/DBI
rm -f blib/lib/DBI/Changes.pm
cp Changes blib/lib/DBI/Changes.pm

[...]

cc -c -D_POSIX_C_SOURCE=199506L -D_HPUX_SOURCE -L/lib/pa1.1 -DUINT32_MAX_BROKEN -mpa-risc-1-1 -I/usr/local/
include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O -DVERSION=\"1.28\" -DXS_VERSION=\"1.28\" -I/opt/perl/lib/5.6.1/PA-RISC1.1-thread-mul
ti/CORE DBI.c

[...]

Running Mkbootstrap for DBI ()
chmod 644 DBI.bs
rm -f blib/arch/auto/DBI/DBI.sl
LD_RUN_PATH="" ld -b -L/usr/local/lib DBI.o -o blib/arch/auto/DBI/DBI.sl
ld: (Warning) At least one PA 2.0 object file (DBI.o) was detected. The linked output may not run on a PA 1.x system.
ld: Invalid loader fixup in text space needed in output file for symbol "$000001AE" in input file "DBI.o"
*** Error exit code 1



Pertinent info:

root@ejl144[256] uname -a
HP-UX ejl144 B.11.11 U 9000/780 2010459265 unlimited-user license

root@ejl144[257] perl -v

This is perl, v5.6.1 built for PA-RISC1.1-thread-multi

(perl -V available on request)

Any ideas appreciated.
5 REPLIES
Scott Van Kalken
Esteemed Contributor

Re: Perl DBI module install fails HP-UX 11.11

which cc are you using?

I'm assuming it's ansiC and not the generic cc bundled that isn't much good for anything other than compiling the kernel.
Hartmut Lang
Trusted Contributor

Re: Perl DBI module install fails HP-UX 11.11

You don't want to use gcc (why not, but ok). But it seems you are using gcc options for compiling (like the -mpa-risc-1-1). This option tells the gcc to produce a PA1.1 object. Your linker warning tells you that you did create a PA2.0 object. Hence the -mpa-risc-1-1 option did not work. That might cause your linker to fail, since you have mixed PA1.x and PA2.o objects.

Solution:
Use gcc or
use the equivalent cc-options for pa1.1 objects.

Hartmut
Rick Grubin
Occasional Visitor

Re: Perl DBI module install fails HP-UX 11.11

 
MANOJ SRIVASTAVA
Honored Contributor

Re: Perl DBI module install fails HP-UX 11.11

 
Hartmut Lang
Trusted Contributor

Re: Perl DBI module install fails HP-UX 11.11

Your problems with GCC:

you are using a GCC compiled for HPUX11.0 on a HPUX11.11 system. That does not work if you have to use specific headers (like socket.h).

See thread:
http://forums.itrc.hp.com/cm/QuestionAnswer/1,,0xbdd191ccb36bd611abdb0090277a778c,00.html

Goto http://devresource.hp.com/LPK/ to load a HPUX11.11 version of the gcc.

Hartmut