Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with B2000 workstations

SUMIT BASU MALLICK
Occasional Contributor

Problem with B2000 workstations

In B2000 workstations ( 55 Nos.)there is a problem that when the systems are shutdowned by pressing the soft switch at the front panel of the workstations ,on the time of restarting the systems the systems gone for the fsck of the Hard disks and come to stop at bcheckrc mode.The shutdown time it is always showing the shutdown completes.

The /etc/shutdownlog is also not logging any thing on the specifed shutdown.

Can you help me ........
10 REPLIES
CHRIS ANORUO
Honored Contributor

Re: Problem with B2000 workstations

You have been crashing your systems!. Please shutdown normally to avoid this situations.
When We Seek To Discover The Best In Others, We Somehow Bring Out The Best In Ourselves.
Andy Monks
Honored Contributor

Re: Problem with B2000 workstations

While not the best way to shut a machine down, it does work (depending on the exact machine) and you are quite right, a B2000 does do this.

However, hitting the power switch doesn't run the shutdown command. The nearest thing that you could type is 'reboot -qh'.

It's down and dirty.

It's far better to use the shutdown command from the command line.

Btw, I always use the power switch to turn off my workstation. However, I don't run anything important on it. Although (like yours) it fsck's on the way up, it (so far) has never had a problem it couldn't fix.
Patrick Wessel
Honored Contributor

Re: Problem with B2000 workstations

The B2000 performs a shutdown -q when you press the power switch. Not the nicest way to bring an OS down?
Do you see the same problem when you use a shutdown -h? If not, I would recommend to use the proper OS command to bring the OS down
There is no good troubleshooting with bad data
T.S.SHIVAKUMAR
Occasional Advisor

Re: Problem with B2000 workstations

Dear Sumit,
It is not a good policy to be using the soft switch for routine shutdown.I suggest you use it only in case of emergency.Else for a quick shutdown you might use "shutdown -qh"
Please let me know if you are from HCL !
(tshiv@miel.mot.com)
Try...try... till your system crashes!
SUMIT BASU MALLICK
Occasional Contributor

Re: Problem with B2000 workstations

I understand that the soft switch shutdown is not the proper way .But as I having the soft switch and if I do that why my system at the time of rebooting come and stuck to bcheckrc prompt. Also I want what routine it is using in O/S level while the shutdown thru. soft switch.

In case of D-class if I use the DC -switch for shutting down, the system may run the fsck ( not always ) but never goes to the bcheckrc prompt.

Also let me know why no entry is coming to /etc/shutdownlog .

Pl. extend your help on this issue......
Patrick Wessel
Honored Contributor

Re: Problem with B2000 workstations

You can find a part of the "HP-UX 10.0 System Startup White Paper" attached to this response. It describes how/why bcheckrc opens up a shell. I hope this answers most of your questions.

The D-Class server does a reboot -h when you power it off, the B2000 performs a shutdown -q. The B2000 turns the power of after a certain time. No matter if the shutdown -q finished or not. The reboot -h takes care about the filesystem, but does not invoke the shutdown scripts
There is no good troubleshooting with bad data
SUMIT BASU MALLICK
Occasional Contributor

Re: Problem with B2000 workstations

The shutdown -q is not a valid command in the hpux 11.0 .As I am giving shutdown -q it is giving errors that -q is not the valid option. Pl. clarify ..........
Patrick Wessel
Honored Contributor

Re: Problem with B2000 workstations

Well, looks like there is a mistake in the manual of the B2000 and I never thought about it. Of cause is there no "shutdown -q", it's a "reboot -qh". Nevertheless is this command a quick but dirty way to bring your system down.
There is no good troubleshooting with bad data
S. Karunanidhi
Occasional Advisor

Re: Problem with B2000 workstations

Hi!
After getting the "bcheckrc" prompt, try running

bcheckrc#fsck -y

Once this is over, run

bcheckrc#reboot -n

There is no reason why your machine again goes into bcheckrc. Don't exit from bcheckrc, instead reboot the machine.

Regs.,
S.Karunanidhi

Karunanidhi.S
SUMIT BASU MALLICK
Occasional Contributor

Re: Problem with B2000 workstations

I always run fsck -y instead of using exit , I am giving once the reboot -n also but the problem is after making the shutdown thru. the soft switch it is giving always the same status.

Pl........