Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with Informix libraries

Ajay Nair
Occasional Advisor

Problem with Informix libraries

Hi,

I'm using 64-bit Informix shared libraries and another 3rd party library that is 32-bit.

Is there any way by which I can make my object file link to both these libraries.

Currently it gives me the error "Mismatched ABI. 64-bit PA shared library found in 32-bit link." and when I compile in 32-bit mode using DAportable and it gives me "Can't find library or mismatched ABI for -lASH" error when I compile in 64-bit mode using DA2.0W.

Please advice me if there is a way out.

Thanks,
Ajay

1 REPLY
Michael Tully
Honored Contributor

Re: Problem with Informix libraries

Hi,

I don't believe you will get this to work. If the 3rd party application is expecting 32 bit shared libraries, it won't run under a 64 bit library. In saying that you can run these 32 bit applications on 64 bit operating systems.
For example I have 32 bit application here, and the vendor insists that it must be run under a 32 bit Informix version. What are the recommendations of the 3rd party vendor who supplies that application?

Michael
Anyone for a Mutiny ?