Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with kaio at running informix 7.3 in HP-UX 11i

Oscar Castillo Murillo
Occasional Advisor

Problem with kaio at running informix 7.3 in HP-UX 11i

At running oninit of informix 7.3 report of following error:

16:36:02 Informix Dynamic Server Version 7.30.UC6
16:36:02 Who: Session(0, @, 0, 0)
Thread(13, kaio, 0, 8)
File: kaio.c Line: 2048
16:36:02 stack trace for pid 8181 written to /tmp/af.de952
16:36:03 See Also: /tmp/af.de952, shmem.de952.0
16:36:03 See Also: /tmp/af.ee952, shmem.ee952.0
16:36:03 Error writing '/tmp/shmem.ee952.0' errno = 28
16:36:03 kaio.c, line 2048, thread 14, proc id 8174, kaiothread() ERROR.
16:36:03 PANIC: Attempting to bring system down
2 REPLIES
A. Clay Stephenson
Acclaimed Contributor

Re: Problem with kaio at running informix 7.3 in HP-UX 11i

The first thing you need to do is increase the space on /tmp because errno 28 is ENOSPC -- filesystem full. Change Informix's temp directory or increase the size of tmp. This won't fix your problem but it will enable a meaningful stack trace for debugging.
If it ain't broke, I can fix that.
Steve Lewis
Honored Contributor

Re: Problem with kaio at running informix 7.3 in HP-UX 11i

Firstly you need to upgrade to Informix DS 7.31. There may be some KAIO bugs left in 7.30 and that is my bet for the cause of this problem.
Secondly as ACS says, change the informix environment variable DBSPACETEMP to be something other than /tmp or make /tmp big enough to hold your instance shared memory. Filling up /tmp is never a good idea.
Lastly have you tuned the value of
IFMX_HPKAIO_NUM_REQ? The default is 1000, but I have tuned it up to 2000 or 3000 before. Your problem may be caused by having this set too low.
Another possible cause is too low a value for NFILE in the kernel. Maybe you should also check your semaphore tunables too.
Make sure you are up-to-date on o/s patches and check the syslog.