Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with number of connections.

Problem with number of connections.

I have HPUX 10-20 running Oracle 7.3.4. What we are noticing are when we had reach 64 connection limit, the system would not allow any further oracle connections to be established. The error codes that are generated are not available. So is there any TCP/IP connection limit that may inhibit the oracle connections. ? The information is sketchy but this is all I have to go by.
12 REPLIES
harry d brown jr
Honored Contributor

Re: Problem with number of connections.


Can you post your kernel parameters?

Take a look at npty.

live free or die
harry
Live Free or Die
Michael Tully
Honored Contributor

Re: Problem with number of connections.

Do your users actually 'login' to your system ? If so, you have most likely run out of pseudo tty devices. These relate directly to your kernel parameter 'npty'. You would need to generate a new kernel and have a short outage whilst your system reboots with a new kernel. To be sure, post you existing kernel parameters.

# cd /stand/build
# /usr/lbin/sysadm/system_prep -s system

post a copy of the system file that gets generated.
Anyone for a Mutiny ?

Re: Problem with number of connections.

My Kernel Parameter
-- npty = 120
-- nstrpty = 60

I will try to post the remaining parameters however I was having difficulty with the command posted. I did exactly as requested, and it just returns back with no errors. What am I doing wrong.?
Michael Tully
Honored Contributor

Re: Problem with number of connections.

As I stated before it seems that your system has run out of pseudo tty devices. You will need to generate a new kernel and have your system reboot with the new kernel. There are two way to go about this. From the command line or you canould use 'sam'.

# cd /stand/build
# /usr/lbin/sysadm/system_prep -s system
# vi system (Make changes the values of 'npty' and 'nstrpty' say at least 500 for each)
save the file

# /usr/sbin/mk_kernel -s system
# mv /stand/vmunix /stand/vmunix_prev
# mv /stand/build/vmunix_test /stand/vmunix

# cd /

Reboot you system
# shutdown -r -y 0

If you are in any way uncomfortable, use 'sam'
Anyone for a Mutiny ?
Bill Hassell
Honored Contributor

Re: Problem with number of connections.

You are very likely out of pty device files. While you can change the kernel parameters, they will be ineffective until you run insf to create the additional device files. Rather than explain all the details, use SAM, and change both npty and nstrpty to 250. SAM will automatically generate the matching device files and re-gen the kernel. This will require a reboot.


Bill Hassell, sysadmin
rick jones
Honored Contributor

Re: Problem with number of connections.

There are no fixed limits to the number of connections in the TCP/IP stack of HP-UX 10.20 (or 11.X for that matter).

As far as TCP is concerned, so long as there is memory enough to hold the connections, it will allow them.

Now, given that a TCP connection is accessed via a socket, and a socket is a file descriptor, the per-process and system-wide limits on the number of open file descriptors does provide an upper bound .
there is no rest for the wicked yet the virtuous have no pillows

Re: Problem with number of connections.

I did change the npty from 120 --> 240, and nstrpty from 60 --> 120, using SAM, and re-booted the system.

No improvement yet, gathering more information and keep you guys posted, and thanks for all your help.

Wodisch
Honored Contributor

Re: Problem with number of connections.

Hi,

how about your Oracle instance's parameters?
- is "processes" big enough?
- do you have sufficient "semmns"? (Ok, that's another kernel parameter)
- do you have enough "dml_locks"?

FWIW,
Wodisch
Wodisch
Honored Contributor

Re: Problem with number of connections.

Hi,

how about your Oracle instance's parameters?
- is "processes" big enough?
- do you have sufficient "semmns"? (Ok, that's another kernel parameter)
- do you have enough "dml_locks"?
- how about "max_files"? (another kernel parameter)

FWIW,
Wodisch
Jeff Schussele
Honored Contributor

Re: Problem with number of connections.

Hi Pheroz,

Have you checked the /var/adm/syslog/syslog.log file for any error msgs when the "ceiling" is hit?
I'm wondering if you don't have the maxuprc (kernel parm) set high enough & you're topping out on it.
This parm defines how many total processes can be spawned under a single user name - like oracle or whatever your oracle username is.
Oracle's a rabbit & wants to spawn lots of processes. If it's in the triple digits as a value - bump it up to several K at least.

HTH,
Jeff
PERSEVERANCE -- Remember, whatever does not kill you only makes you stronger!
T G Manikandan
Honored Contributor

Re: Problem with number of connections.

Oracle in a shared environment is much different than running Oracle on a dedicated server.
I am not sure whether you are running the database is the shared mode.
Check your $ORACLE_HOME/dbs/init file to check whether you have limited the number of concurrent connections.

Do you have somtthing like
max_sessions
or
#mts_dispatchers

to some specific value.

Thanks
Ru Lou
Occasional Visitor

Re: Problem with number of connections.

You probably resolved your problem by now. You
may need to rebuild the special device file by issue: insf -d ptys -n 512 (or whatever)
insf -d ptym -n 512
See DOC# KBRC0000945