Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

Proper locale setting for Oracle DB unicode support

John Mathieu
Occasional Visitor

Proper locale setting for Oracle DB unicode support

We have been encountering issues with reading an Oracle DB with our HP-UX itanium system with SAS 9.1.3 or SQLPLus. The Oracle Exadata DB is Unicode but will not have any languauge support other than American.

What must the locale setting be to enable the oracle client on our server to read the remote database ?

Our current systems settings for locale.

LANG=
LC_CTYPE="C"
LC_COLLATE="C"
LC_MONETARY="C"
LC_NUMERIC="C"
LC_TIME="C"
LC_MESSAGES="C"
LC_ALL=

Locale settings available for English US.
en_US.iso88591
en_US.roman8
4 REPLIES
Volker Borowski
Honored Contributor

Re: Proper locale setting for Oracle DB unicode support

Hi,

I'd give

LANG=en_US.iso88591
NLS_LANG=AMERICAN_AMERICA.UTF8

a try, if the DB is 8 Bit, but could be
16 Bit UTF as well, depending on what is configured in the DB.
Check V$NLS_PARAMETER and the DB charset for that.

You have the correct client SW version in place?

Volker
John Mathieu
Occasional Visitor

Re: Proper locale setting for Oracle DB unicode support

The oracle DB is defined as AL32UTF8.

The oracle client we have installed and enbled for SAS support is 10gR2.

SAS documentation is not specific how to enable the operating system environment but does indicate that the characterset should be set for NLS_LANG to either AL32UTF8 or UTF8.

What are the commands required to set the LANG and LC_ALL values properly and are these two that must be set ?


John Mathieu
Occasional Visitor

Re: Proper locale setting for Oracle DB unicode support

Also for the NLS_LANG setting.
Is this for the oracle client and what is the best method to enable this setting ?

Will case matter when defining the NLS_LANG version ?
Volker Borowski
Honored Contributor

Re: Proper locale setting for Oracle DB unicode support

Hi,

these are simple environment variables.
They are to be set according to the shell the
user is using (csh / sh).

so either
setenv ...
or
export ...

is the way to go. (Did I get something wrong?)

Doing a google with
"SAS 9.1.3 NLS_LANG AL32UTF8"
results only in a very few hits...

Volker