cancel
Showing results for 
Search instead for 
Did you mean: 

RMAN Error

Nagendra Shastry K,C
Occasional Advisor

RMAN Error


Hi,

I am getting the error while taking the backup of the Oracle database using RMAN.
There error stack is as below.

-------------------------------------------------------------

Starting backup at 27-NOV-06
channel t1: starting full datafile backupset
channel t1: specifying datafile(s) in backupset
input datafile fno=00008 name=DATA10:[ORADATA.TRMAN]USERS_TEST_001.DBS
channel t1: starting piece 1 at 27-NOV-06
BETA2::SYSTEM 02:14:56 RMAN CPU=00:01:24.36 PF=242272 IO=232737 MEM=2522
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-00601: fatal error in recovery manager
RMAN-03004: fatal error during execution of command
RMAN-10038: database session for channel t1 terminated unexpectedly

-------------------------------------------------------------
The above error I am getting while taking the backup of date >3GB as well as
I am using the MSL library, ( FC connected )

This is intermittant.

Please help me on this .

-Nagendra
10 REPLIES
Peter Godron
Honored Contributor

Re: RMAN Error

Hi,
and welcome to the forums !

Please see earlier thread:
http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=808931

Please also read:
http://forums1.itrc.hp.com/service/forums/helptips.do?#33 on how to reward any useful answers given to your questions.
Yogeeraj_1
Honored Contributor

Re: RMAN Error

hi Nagendra!

are you using RMAN compression feature? (assuming this is Oracle 10g)

kind regards
yogeeraj

No person was ever honoured for what he received. Honour has been the reward for what he gave (clavin coolidge)
Ben Dehner
Trusted Contributor

Re: RMAN Error

The RMAN client has to connect to the database, and somehow that session is getting killed. I'd suggest looking in the alert log, or checking for trace files/core dumps for an abnormal client termination.
Trust me, I know what I'm doing
Nagendra Shastry K,C
Occasional Advisor

Re: RMAN Error

Hi,

No, i am using ORACLE 92.

Actually the problem is While taking the backup (using SBT calls) it is giving this error. In the SBT log file it is clearly showing successfull completion of the BACKUP.

In ALERT log file i seen redo log activity and achiving of the *.ARC file. While archiving the *.ARC file it got "NO DISK SPACE" error. after some point of time some process has deleted some file and archiving proceeded normally.

My question is:
1. Archiving of *.ARC file done after each backup.

2. I have enabled the ARCHIVING In SQL. but if after the backup (USING RMAN + SBT calls) the archiving has not started.
what else i need to do to log this?

3. what i should i need to enable so that i can get the (atleast) information about the starting of the SBT calls or end of the SBT calls ( Other than SBT log file ).

4. Is it the SGA may cause this problem


Yogeeraj_1
Honored Contributor

Re: RMAN Error

hi,

to verify if your system is running on archive log mode, do the following:

sqlplus "/as sysdba"

then run:
archive log list


kind regards
yogeeraj
No person was ever honoured for what he received. Honour has been the reward for what he gave (clavin coolidge)
Nagendra Shastry K,C
Occasional Advisor

Re: RMAN Error

Hi

SQL> Archive log list;
Database log mode Archive Mode
Automatic archival Disabled
Archive destination NODE$DKB1100:[ORACLE92.ORADATA.B1234]
Oldest online log sequence 41
Next log sequence to archive 43
Current log sequence 43

point 3 has been solved after running the below command

RMAN> configure controlfile autobackup on

How to enable the "Automatic archival"

Thanks
/Nagendra
Nagendra Shastry K,C
Occasional Advisor

Re: RMAN Error

Hi

SQL> Archive log list;
Database log mode Archive Mode
Automatic archival Disabled
Archive destination NEPAL$DKB1100:[ORACLE92.ORADATA.B1234]
Oldest online log sequence 41
Next log sequence to archive 43
Current log sequence 43

point 3 has been solved after running the below command

RMAN> configure controlfile autobackup on

How to enable the "Automatic archival"

Thanks
/Nagendra
Yogeeraj_1
Honored Contributor

Re: RMAN Error

hi,

To enable ARCHIVELOG Mode, the following steps are required:

1. verify that the flashback_recovery_area is setup:
SQL> show parameters db_recovery

if the flashback_recovery_area is setup, the query will return a value for db_recovery_file_dest and db_recovery_file_dest_size

if the flashback_recovery_area is setup, then the destination specified by the db_recovery_file_dest parameter is used as the archivelog destination, and you do not need to specify the destination directory for your archives in the following step.

2. Specify the destination for your archives by including the initialisation parameter LOG_ARCHIVE_DEST_n in the initialisation file. If spfile is used, then the following command can be issued:
SQL> alter system set log_archive_dest_n="LOCATION=" scope=spfile;

where in the log_archive_dest_n parameter, n is the number of 1 through 10.

if pile is used, the following initialisation file must be edited:

$ORACLE_HOME/dbs/initSID.ora

You should change the LOG_ARCHIVE_DEST_n parameter to:
log_archive_dest_n="LOCATION="

You should also specify the LOG_ARCHIVE_FORMAT in the initialisation file . The format can be specified as follows:
LOG_ARCHIVE_FORMAT='log%t_$r_%s.arc'

where t = the thread number
r = rest log ID
s = sequnce number

3. Make sure that the ORACLE_HOME and ORACLE_SID environment variables are properly set.

4. Make sure that no one is using the database.

5. Perform a clean, normal shutdown of the database instance.

$ sqlplus '/as sysdba'
SQL> shutdown immediate

6. Start up the instance and mount, but do not open the database.
SQL> startup mount

7. Enable Database ARCHIVELOG mode
SQL> alter database archivelog;

8. Shutdown and restart the database instance

9. Re-verify that the database is now in ARCHIVELOG mode



these are the full steps.

hope this helps!

kind regards
yogeeraj
No person was ever honoured for what he received. Honour has been the reward for what he gave (clavin coolidge)
Yogeeraj_1
Honored Contributor

Re: RMAN Error

hi again,

before you try the above steps, since you are already in archive log mode, please to issue a:

sqlplus '/as sysdba'
SQL> archive log start;

and verify if the archive log file is created in the destination (log_archive_dest_n)

hope this helps!

kind regards
yogeeraj
No person was ever honoured for what he received. Honour has been the reward for what he gave (clavin coolidge)
William Lai
Occasional Visitor

Re: RMAN Error

Hi Nagendra,

You have,
a) oracle9iR2 database
b) database is in ARCHIVELOG mode
c) archiver is NOT start automatically

Since you have database in ARCHIVELOG mode, please ensure that automatic archiving is configure.

-- check log_archive_start are set to TRUE
select name, value
from v$parameter
where name = 'log_archive_start'
;
-- set log_archive_start to true
-- assuming you are using spfile
alter system set log_archive_start=true scope=spfile
;
-- restart database instance
shutdown immediate;
startup;

Regards,
William