cancel
Showing results for 
Search instead for 
Did you mean: 

Snapshots issue

Andres_13
Respected Contributor

Snapshots issue

Hi gurus,

Last weekend i did backups using snapshots but something goes grong:

Stop database, mount snapshots (about 84 logical volumes. Most 42 gb) and restarts database.

First 5 filesystems got corrupted when data protector was back it up, then stop database again, mount all snapshots and restarts database.

Once backup was running the number of zombies proc reported by top grows (it reports one minute 39 zombies, next minute it was 2243). Server and backup performance seems to be degraded (backup has been running by about 18 hours, normally it takes 7 hours with 4 LTO 3 drives in 2 MSL6060 tape library).

HP-UX 11.23, OnlineJFS 3, Oracle 92, sap NW 6, overall database space about 2.8 TB...

I want to know if maybe i've missed something, command to mount snapshots:

mount -F vxfs -o snapof=/FS1 /dev/vgsnp/lvol1 /snapshot/FS1

All original filesystems are largefiles capables.

If i miss something pls ask and it will be posted.

Regards!
4 REPLIES
A. Clay Stephenson
Acclaimed Contributor

Re: Snapshots issue

Nothing appears to be wrong with your snapshot mount syntax. Of course, if you have 84 snapshots, that's 84 chances to get something wrong. I've used the snapshot technique to backup Oracle for many years and haven't seen anything like your problems.

One of the things that can cause snapshots to behave badly is a bad snapshot buffer area (e.g. your /dev/vgsnp/lvol1). It's a very good idea to mirror this LVOL (or if it's an array LUN, make sure that multiple paths are available) because should the disk housing the LVOL fail that can cause the original filesystem to hang.
If it ain't broke, I can fix that.
Andres_13
Respected Contributor

Re: Snapshots issue

Thanks A. Clay for your quick response.

All disks are on a XP24000, RAID 5, 146 gb, 15 krpm. I think i do not need to do an explicit mirror of this vg, right (see attached)?

Maybe need to try use that disks as a raw devices?

Regards!
Andres_13
Respected Contributor

Re: Snapshots issue

Just FYI,

After a couple of hours work around the issue i saw that there was 5 filesystem seen like "IO error" by bdf command. Unfortunately i can´t be able to know what causes this corruption. Clues about where to look?

Regards!
Andres_13
Respected Contributor

Re: Snapshots issue

The issue have never happened again.