Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to Install oracle req patch :PHSS_39824 [ HP C/aC++ Compiler (A.06.23) ]

RAJD1
Valued Contributor

Unable to Install oracle req patch :PHSS_39824 [ HP C/aC++ Compiler (A.06.23) ]

Hi Experts,

I am unable to install the oracle required patch PHSS_39824 on 11.31 system .

I have downloaded the patch and its dependecy per itrc patch site. and it is giving error.

 

 

# checking the downloaded depot products:


serverA:>swlist -l product @  /var/adm/crash/PHSS_39824_patch/depot     #Listing from patch depot.
# Initializing...
...

  PHSS_39824    1.0            HP C/aC++ Compiler (A.06.23)
  PHSS_40633    1.0            u2comp/be/plugin (C.06.24)
#-----------------------------------------------------------------------------

 

 

 

# Trying install in preview mode:

# swinstall -p -s /var/adm/crash/PHSS_39824_patch/depot PHSS_39824 PHSS_40633   

 

=======  11/17/11 07:11:49 BRST  BEGIN swinstall SESSION
         (non-interactive) (jobid=serverA-1176)

       * Session started for user "root@serverA".

       * Beginning Selection
       * Target connection succeeded for "serverA:/".
       * Source connection succeeded for
         "serverA:/var/adm/crash/PHSS_39824_patch/depot".
ERROR:   Could not apply the software selection "PHSS_39824" because
         there are no product variations that are compatible with the
         destination host(s).
       * Software selection failed for
         "serverA:/var/adm/crash/PHSS_39824_patch/depot".
ERROR:   Could not apply the software selection "PHSS_40633" because
         there are no product variations that are compatible with the
         destination host(s).
       * Software selection failed for
         "serverA:/var/adm/crash/PHSS_39824_patch/depot".
ERROR:   No software has been selected.
ERROR:   Cannot continue the "swinstall" task.
       * Selection had errors.


=======  11/17/11 07:11:53 BRST  END swinstall SESSION
         (non-interactive) (jobid=serverA-1176)

 

 

 

 

 

 

 

Current  c++ componenets are on the system:

swlist -l product | grep -i -e c+ -e C-ANSI
  ACXX                  C.03.85        HP aC++
  C-ANSI-C              B.11.11.20     HP C/ANSI C Compiler
  PHSS_38141            1.0            aC++ Runtime (IA: A.06.20, PA: A.03.85)
serverA:>uname -a
HP-UX serverA B.11.31 U 9000/800 13669933444 unlimited-user license

 

# hp-ux version:

HPUX11i-DC-OE         B.11.31.1009   HP-UX Data Center Operating Environment

#-----------------------------------------------------------------------------------------------------

 

 

 

 

Please advise whats wrong , why getting the error  "there are no product variations that are compatible with the         destination host(s)."

 

Thanks,

 

 

11 REPLIES
Patrick Wallek
Honored Contributor

Re: Unable to Install oracle req patch :PHSS_39824 [ HP C/aC++ Compiler (A.06.23) ]

The patch PHSS_39824 is for C/aC++ verion A.06.23.  You don't have that on your system.

 

According to your swlist you have:
  ACXX                  C.03.85        HP aC++

 

So this patch does not apply to you.

 

The requirement from Oracle is assuming an older version of the C compiler.  Since you appear to have a newer verison, this patch requirement can be ignored.

 

 

Dennis Handly
Acclaimed Contributor

Re: Unable to Install Oracle req patch: PHSS_39824 [HP C/aC++ Compiler (A.06.23)]

>I am unable to install the oracle required patch PHSS_39824 on 11.31 system.

 

In addition to what Patrick said, that patch is for an Integrity server.  You have a PA box.

That's why you get:

"there are no product variations that are compatible with the destination host(s)."

RAJD1
Valued Contributor

Re: Unable to Install Oracle req patch: PHSS_39824 [HP C/aC++ Compiler (A.06.23)]

Both reply make sense for the above scenario,   Thank you Patrick and Dennis.  Kudos!.

RAJD1
Valued Contributor

Re: Unable to Install Oracle req patch: PHSS_39824 [HP C/aC++ Compiler (A.06.23)]

Hi Patrick , Dennis, all,

 

Now oracle team given a new patch to install  :   PHSS_40631   ---  11.31 HP C/aC++ Compiler (A.06.24) .

 

- But after downloaded , created depot and analysed , this patch also giving same error. 

 

 

 

swinstall -p -s /var/adm/crash/patch_PHSS_40631_c++/depot PHSS_40631 PHSS_40633

=======  11/20/11 11:09:54 BRST  BEGIN swinstall SESSION
         (non-interactive) (jobid=ServerA-1182)

       * Session started for user "root@ServerA".

       * Beginning Selection
       * Target connection succeeded for "ServerA:/".
       * Source connection succeeded for
         "ServerA:/var/adm/crash/patch_PHSS_40631_c++/depot".
ERROR:   Could not apply the software selection "PHSS_40631" because
         there are no product variations that are compatible with the
         destination host(s).
       * Software selection failed for
         "ServerA:/var/adm/crash/patch_PHSS_40631_c++/depot".
ERROR:   Could not apply the software selection "PHSS_40633" because
         there are no product variations that are compatible with the
         destination host(s).
       * Software selection failed for
         "ServerA:/var/adm/crash/patch_PHSS_40631_c++/depot".
ERROR:   No software has been selected.
ERROR:   Cannot continue the "swinstall" task.
       * Selection had errors.

 

=======  11/20/11 11:09:57 BRST  END swinstall SESSION
         (non-interactive) (jobid=ServerA-1182)

#----------------------------------------------------------------------------------------------------

 

 

Patch listing of the depot:

ServerA:>swlist -l product @ /var/adm/crash/patch_PHSS_40631_c++/depot
# Initializing...
# Contacting target "ServerA"...
#
# Target:  ServerA:/var/adm/crash/patch_PHSS_40631_c++/depot
#

  PHSS_40631    1.0            HP C/aC++ Compiler (A.06.24)
  PHSS_40633    1.0            u2comp/be/plugin (C.06.24)
ServerA:>

 

 

 

Please advise whats worng for this version too, getting  same error "there are no product variations that are compatible with the   destination host(s)."
,

 

 

Thanks,

 

 

 

 

Dennis Handly
Acclaimed Contributor

Re: Unable to Install Oracle req patch: PHSS_40631 - 11.31 HP C/aC++ Compiler A.06.24

>Now oracle team given a new patch to install: PHSS_40631 - 11.31 HP C/aC++ Compiler A.06.24.

 

Stop.  Again, this is an Integrity server patch.

 

There are NO patches for your PA A.03.85.  The latest version is A.03.95.

http://h21007.www2.hp.com/portal/site/dspp/menuitem.863c3e4cbcdc3f3515b49c108973a801/?ciid=2645dec4c7563110VgnVCM100000275d6e10RCRD#b11.31pa

RAJD1
Valued Contributor

Re: Unable to Install Oracle req patch: PHSS_40631 - 11.31 HP C/aC++ Compiler A.06.24

Dennis,

 

Great , thanks.  Now it makes me understand that due to itanium patch it is not applicable ,

The link i couldnt open btw,  giving error:  

Document unavailableHP

AllianceONE Partner Program

 

 

Thanks, Kudos...

Dennis Handly
Acclaimed Contributor

Re: Unable to Install Oracle req patch: PHSS_40631 - 11.31 HP C/aC++ Compiler A.06.24

>The link I couldn't open btw,  giving error:  Document unavailable HP AllianceONE Partner Program

 

You need to become an AllianceONE member.  Registration is free and it uses HP Passport.

http://www.hp.com/go/AllianceONE

nice_nidhi
Occasional Contributor

Re: Unable to Install oracle req patch :PHSS_39824 [ HP C/aC++ Compiler (A.06.23) ]

Hi Experts,I am unable to install the oracle required patch PHSS_40631on 11.31 Integrity Server .I have downloaded the patch and its dependecy per itrc patch site. and it is giving the below error. #
 
Please help me I am stucked in middle of an important task
 
NOTE:    The patch fileset "PHSS_40631.ACXX,r=1.0" may only be             │
│ │          installed upon a previously installed base fileset.  The          │
│ │          specification for this base fileset is                            │
│ │          "ACXX.ACXX,fr=C.06.20,v=HP".  Since there is no fileset on the    │
│ │          target or selected from the source which matches this             │
│ │          specification, fileset "PHSS_40631.ACXX,r=1.0" will be            │
│ │          excluded.                                                         │
│ │ NOTE:    The patch fileset "PHSS_40631.ACXX-STDLIB,r=1.0" may only be 
installed upon a previously installed base fileset.  The         ^│
│ │          specification for this base fileset is                            │
│ │          "ACXX.ACXX-STDLIB,fr=C.06.20,v=HP".  Since there is no fileset    │
│ │          on the target or selected from the source which matches this      │
│ │          specification, fileset "PHSS_40631.ACXX-STDLIB,r=1.0" will be     │
│ │          excluded.                                                         │
│ │ NOTE:    The patch fileset "PHSS_40633.LANG-AUX,r=1.0" may only be         │
│ │          installed upon a previously installed base fileset.  The          │
│ │          specification for this base fileset is                            │
│ │          "Auxiliary-Opt.LANG-AUX,fr=C.06.20,v=HP".  Since there is no      │
│ │          fileset on the target or selected from the source which           │
│ │          matches this specification, fileset              
    "PHSS_40633.LANG-AUX,r=1.0" will be excluded.                     │
│ │        * Executing preDSA command.                                         │
│ │ NOTE:    Could not install the bundle "BUNDLE,r=B.2011.11.30" because      │
│ │          none  of its filesets could be installed.                         │
│ │                                                                            │
│ │        * Summary of Analysis Phase:                                        │
│ │        * 3 of 3 filesets will be Skipped.                                  │
│ │        * The Analysis Phase succeeded.        
Dennis Handly
Acclaimed Contributor

Re: Unable to Install Oracle req patch: PHSS_40631 - 11.31 HP C/aC++ Compiler A.06.24

>I am unable to install the oracle required patch PHSS_40631 on 11.31 Integrity Server.

 

This is not a "required" patch.  You must meet several conditions:

You first need to do development on that server and actually have the aC++ compiler installed.

 
NOTE:    The patch fileset "PHSS_40631.ACXX,r=1.0" may only be
│             installed upon a previously installed base fileset.  The
│             specification for this base fileset is  "ACXX.ACXX,fr=C.06.20,v=HP".

 

This means what it says.  You must have A.06.20 installed before you can patch it to A.06.24.

http://h21007.www2.hp.com/portal/site/dspp/menuitem.863c3e4cbcdc3f3515b49c108973a801/?ciid=8b080f1bace021100f1bace02110275d6e10RCRD#b11.31

 

The latest version is A.06.26.

nice_nidhi
Occasional Contributor

Re: Unable to Install Oracle req patch: PHSS_40631 - 11.31 HP C/aC++ Compiler A.06.24

Thanks for the help Dennis.

 

I have already installed the trail version of HP C/aC++ Developer's Bundle for Evaluation - HP-UX 11i v3 (B.11.31) A.06.26 - For Integrity.

 

# swlist -l product|grep -i aC++
  ACXX                  C.06.26.EVAL   HP C/aC++ Compiler
  C-ANSI-C              C.06.26.EVAL   HP C/aC++ Compiler
  PHSS_41185            1.0            aC++ Runtime (IA: A.06.25.01, PA: A.03.90)
#

 

As checked the below link provided by you http://h21007.www2.hp.com/portal/site/dspp/menuitem.863c3e4cbcdc3f3515b49c108973a801/?ciid=8b080f1bace021100f1bace02110275d6e10RCRD#b11.31

 

 the below patches are already installed on the server

 

# swlist -l product|grep -iE "PHSS_41185|PHSS_42040|PHSS_41496|PHSS_42041|PHSS_41494|PHSS_42042"
  PHSS_41185            1.0            aC++ Runtime (IA: A.06.25.01, PA: A.03.90)
  PHSS_41494            1.0            milli cumulative patch
  PHSS_41496            1.0            Integrity Unwind Library
  PHSS_42040            1.0            linker + fdp cumulative patch
  PHSS_42041            1.0            Math Library Cumulative Patch
  PHSS_42042            1.0            assembler patch
#

But still I am getting the below error when trying to install PHSS_40631 along with PHSS_40633.Please help me on this

 

The patch fileset "PHSS_40631.ACXX,r=1.0" may only be installed upon a previously installed base fileset.  The specification for this base fileset is         "ACXX.ACXX,fr=C.06.20,v=HP".  Since there is no fileset on the target or selected from the source which matches this specification, fileset "PHSS_40631.ACXX,r=1.0" will be excluded.  

NOTE:    The patch fileset "PHSS_40631.ACXX-STDLIB,r=1.0" may only be installed upon a previously installed base fileset.  The specification for this base fileset is  "ACXX.ACXX-STDLIB,fr=C.06.20,v=HP".  Since there is no fileset on the target or selected from the source which matches this  specification, fileset "PHSS_40631.ACXX-STDLIB,r=1.0" will be excluded.    

 NOTE:    The patch fileset "PHSS_40633.LANG-AUX,r=1.0" may only be installed upon a previously installed base fileset.The specification for this base fileset is "Auxiliary-Opt.LANG-AUX,fr=C.06.20,v=HP".  Since there is no fileset on the target or selected from the source which matches this specification, fileset "PHSS_40633.LANG-AUX,r=1.0" will be excluded.Executing preDSA command.

 

Dennis Handly
Acclaimed Contributor

Re: Unable to Install Oracle req patch: PHSS_40631 - 11.31 HP C/aC++ Compiler A.06.24

>I have already installed the trial version of HP C/aC++ Developer's Bundle for Evaluation - HP-UX 11i v3 (B.11.31) A.06.26 - For Integrity.

 

Any particular reason?

If you do, you can't apply PHSS_40631, since A.06.26 is newer than A.06.24.

 

Basically you need to ignore what Oracle says when it doesn't make sense.