Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to connect to TOAD /PLSQL developer

satesh
Occasional Visitor

Unable to connect to TOAD /PLSQL developer

Hi
I am able to connect SQL Plus but unable to connect TOAD /PLSQL developer getting error msg
ORA-12705: Invalid or unknown NLS parameter value specified
5 REPLIES
Jonathan Fife
Honored Contributor

Re: Unable to connect to TOAD /PLSQL developer

I would guess that your NLS_LANG environment variable isn't set correctly. If you're running SQL Developer from Windows I believe this is a registry setting in HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE and various subdirectories from there.
Decay is inherent in all compounded things. Strive on with diligence
dineshkumarv
Occasional Visitor

Re: Unable to connect to TOAD /PLSQL developer

Hi satesh

kindly make sure whether ur plsql dev or toad using the same oracle home which is used by ur sqlplus/oracle client

with regards
Dinesh
Sean Dale
Trusted Contributor

Re: Unable to connect to TOAD /PLSQL developer

I set the NLS_LANG parameter as a system environment variable and everything works fine on my computer.
Live life everyday
Yogeeraj_1
Honored Contributor

Re: Unable to connect to TOAD /PLSQL developer

hi,

do you have several oracle homes on the client?

If yes, on the connect window, click on the "SQL*Net Help" button and set the appropriate "TOAD" home.


hope this helps!

yogeeraj
No person was ever honoured for what he received. Honour has been the reward for what he gave (clavin coolidge)
Frank de Vries
Respected Contributor

Re: Unable to connect to TOAD /PLSQL developer

It means only one thing:

You need to specify the NLS_LANG parameter.
Possible values are:
AMERICAN_AMERICA.WE8ISO8859P1

Now if you are not sure about which ORACLE_HOME then add them in your registry
for each ORACLE_HOME
thus: start run: type regedit
HKEY_LOCAL_MACHINE\software\oracle
Edit new string value NLS_LANG
value AMERICAN_AMERICA.WE8ISO8859P1
and the same for each ..\HOME0
..\HOME1 etc..

ALso if you have an older TOAD you may add
under controlpanel system environment variable set NLS_LANG=AMERICAN_AMERICA.WE8ISO8859P1
But that only makes sense if your ORACLE_HOME is in the %PATH% variable and
ORACLE_HOME is set.

But I would try the registry first.
Look before you leap