Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to load software using swinstall

SOLVED
Go to solution
Joe Robinson_2
Super Advisor

Unable to load software using swinstall

While attempting to install JetAdmin on my 10.23 box I get the following error:

"orhp3:/": The operation you have attempted is only allowed on target machines which have HP OpenView Software Distributor installed. To perform this operation, first run the HP OpenView Software distributor pushAgent.

I've installed the pushAgent, but still am unable to load the software as the system still thinks it needs to know that target path. What am I missing here?
5 REPLIES
Frederic Sevestre
Honored Contributor

Re: Unable to load software using swinstall

Hi,
The PushAgent is needed if you want to install a product from a server to an other. The source server must be a server SD running HP OpenView Software Distributor.

In that case you need to to run the PushAgent from the server SD :
pushAgent -m

then on the target allowed the server to proceed the installation using swacl :
swacl -l root -M user:root:a \*
swacl -l root -M user:install:a \*

It should work.

Other way : copy your depot on the target server an install jetadmin from it, you won't need pushAgent.


Crime doesn't pay...does that mean that my job is a crime ?
Sanjay_6
Honored Contributor
Solution

Re: Unable to load software using swinstall

Ho Joe,

Check the host name resolution for your system. Is your system name and ip being resolved correctly.

Do a "nslookup" and the see if your hostname and ip's are correctly resolved. This is a problem with your hostname and ip resolution.

nslookup
>system_name
>system_ip
>exit

Hope this helps.

Regds
Sanjay_6
Honored Contributor

Re: Unable to load software using swinstall

Hi Joe,

Also try to kill and restart your swagentd.

/sbin/init.d/swagentd stop
/sbin/init.d/swagentd start

Hope this helps.

Regds

Roger Baptiste
Honored Contributor

Re: Unable to load software using swinstall

hi,

check the SW setup on your system. Are you able to run
#swlist

Is you swagent daemon running
ps-ef |grep swagentd

Restart swagent, to make sure
it is working fine
/sbin/init.d/swagentd stop

/sbin/init.d/swagentd start

Also, is this sytem on the network??If not, you would need to run swinstall on a standalong mode.

-raj

Take it easy.
Joe Robinson_2
Super Advisor

Re: Unable to load software using swinstall

Thanks for all who replied. I'd found a link on another thread about the reverse DNS lookup failing; when I added that on my DNS lookup table it fixed the problem (although why installing the software from a local file system should need reverse DNS is beyond me).

thanks again!