Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

Uses a character set warning msg

SOLVED
Go to solution
Belinda Dermody
Super Advisor

Uses a character set warning msg

This message uses a character set that is not supported by the Internet Service. To view the original message content, open the attached message. If the text doesn't display correctly, save the attachment to disk, and then open it using a viewer that can display the original character set.

How can I get rid of this msg when mailx files from my 9000/K200 running 10.20
4 REPLIES
Helen French
Honored Contributor

Re: Uses a character set warning msg

Hi,

What options are you using with mailx command ? Are you using a default header file ? If yes, then remove that option or remove the file.

HTH,
Shiju
Life is a promise, fulfill it!
Belinda Dermody
Super Advisor

Re: Uses a character set warning msg

I just use the basic mailx command
mailx -s "SUBJECT" address < file to mail
Bill Hassell
Honored Contributor

Re: Uses a character set warning msg

The message displayed has to do with the MS Exchange server. If the client is setup as an internet client (POP CLIENT) the problem/message doesn't occur.

The problem does NOT occur with GroupWise or any other server/client EXCEPT MicroSoft Exchange server.

The following Headers are added by the mailx program:

HMime-Version: 1.0
HContent-Type: text/plain; charset=X-roman8
HContent-Transfer-Encoding: 7bit

All mime compatible mailers should have no problem with this form. It appears Microsoft Exchange has to be fixed or reconfigured to properly handle this basic MIME format.

You can use the following workarounds:

1. Use mail instead of mailx. Mail doesn't add the mime headers.

2. Use sendmail directly.

/usr/sbin/sendmail -v username@cpu.comp.org < /etc/issue

However, sendmail does not have a command line option for a title so you may want to insert a title like this:

echo "Subject: Some sort of title \n $(cat your_file) | /usr/sbin/sendmail -v username@cpu.comp.org

The word: Subject: followed by a blank line wil add the subject.



Bill Hassell, sysadmin
Helen French
Honored Contributor
Solution

Re: Uses a character set warning msg

Hi,

Another try: Use '-m' or '-N' with mailx command. -m will not add any mime headers.

Check man pages of mailx

HTH,
Shiju
Life is a promise, fulfill it!