Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

Why Oracle 9i need Java SDK?

SOLVED
Go to solution

Why Oracle 9i need Java SDK?

Hi All,
I am doing an installation of Oracle 9i on HP 11.11i. OUI is asking for HOme of SDK which never happen when I installed Oracle 8.1.7.4 on the same HP machine. Does any one knows why SDK is needed? I mean which feature of ORacle 9i uses it.

Thanks
SushiL Singh
7 REPLIES
Steven E. Protter
Exalted Contributor

Re: Why Oracle 9i need Java SDK?

Both versions of oracle mentioned above require at least the Java Runtime Environment. They use it for critical database operations. SDK includes JRE, so perhaps thats why your 8.1.7.4 database worked.

SDK is required for development of certain kinds of objects on the server.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Jeff Schussele
Honored Contributor

Re: Why Oracle 9i need Java SDK?

Hi Sushil,

I couldn't give you a specific reason, but I've seen application SW that needed the SDK because it needed library files that only the SDK had. They weren't in the JRE pkg. I suspect that's the case here.

Rgds,
Jeff
PERSEVERANCE -- Remember, whatever does not kill you only makes you stronger!

Re: Why Oracle 9i need Java SDK?

Thanks Steven,
OUI is installing JRE, even in ORACLE 8.1.7.4, but this is the first time it asked for SDK

Thanks
Sushil Singh
T G Manikandan
Honored Contributor
Solution

Re: Why Oracle 9i need Java SDK?

Uptil now JRE is enough to bring the GUI windows like netasst,dbassist.

Oracle 9i requires SDk because of Oracle http server.

So this is a pre-requisite.

Thanks
Ravi_8
Honored Contributor

Re: Why Oracle 9i need Java SDK?

Hi Sushil

you have choosen default to install.
Choose custom install and don't select HTTP in the list given by OUI. this time it wouldn't ask for SDK.

since HTTP needs sdk(java) to operate, it(SDK) is prerequisite if you choose HTTP in OUI
never give up
Wodisch
Honored Contributor

Re: Why Oracle 9i need Java SDK?

Hi,

well IMHO the 9i installer is broken - even if you do NOT install the web server (http), it does request the Java Runtime. Well, it shouldn't...
Just ignore it - you'll have to waste the ~80MB for it.

FWIW,
Wodisch

Re: Why Oracle 9i need Java SDK?

Thank all of you.

Jugding from response I got, I went through oracle installation guide just to be, and found that JDK is a required piece. Generally it is install directly by OUI for Linux and Solaris, but for HP and AIX, we need to install it.

Thanks Again