Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

autofs - some mounts not using NFS 3

SOLVED
Go to solution
Geoff Wild
Honored Contributor

autofs - some mounts not using NFS 3

We recently upgraded 2 SAP db servers from V-Class with HP-UX 11.0 to RP7410's with HP-UX 11.i.
We have 3 APP servers (N-Class with HP_UX 11.0) that automount filesystems on the db servers. For some reason, some of the mounts are nfs 2 ans some are nfs 3 - and these are NOT consistant across the APP servers:

Output of nfsstat -m

On one server:

/tmp_mnt/data/sap/IPR/ARCHIVE from iprdbf:/export/data/sap/IPR/ARCHIVE
Flags: vers=3,proto=udp,auth=unix,hard,intr,link,symlink,devs,rsize=8192,wsize=8192,retrans=5

On another:

/tmp_mnt/data/sap/IPR/ARCHIVE from iprdbf:/export/data/sap/IPR/ARCHIVE
Flags: vers=2,proto=udp,auth=unix,hard,intr,dynamic,devs,rsize=8192,wsize=8192,retrans=5

Why is this an issue? Well, Version 2 NFS does,'t support files greater than 2GB - version 3 does.

How do I force automount to use Version 3?

BTW rpcinfo -p shows that the boxes support NFS 3:

100003 2 udp 2049 nfs
100003 3 udp 2049 nfs



Proverbs 3:5,6 Trust in the Lord with all your heart and lean not on your own understanding; in all your ways acknowledge him, and he will make all your paths straight.
6 REPLIES
Geoff Wild
Honored Contributor

Re: autofs - some mounts not using NFS 3

Whoops - this shouldn't be under the "Databases" forum - sorry about that....
Proverbs 3:5,6 Trust in the Lord with all your heart and lean not on your own understanding; in all your ways acknowledge him, and he will make all your paths straight.
Domenico_5
Respected Contributor

Re: autofs - some mounts not using NFS 3

hi geof they have the same level of patch?

nfs can work in tcp or udp and depend on a patch .

regards
Geoff Wild
Honored Contributor

Re: autofs - some mounts not using NFS 3

Patches are the same on the APP servers - some of the mounts are nfs3 and some are nfs 2....
Proverbs 3:5,6 Trust in the Lord with all your heart and lean not on your own understanding; in all your ways acknowledge him, and he will make all your paths straight.
S.K. Chan
Honored Contributor
Solution

Re: autofs - some mounts not using NFS 3

On your client find out if you're using the "old" automounter or the "new" automounter.
# ps -ef |grep auto
If it shows "/usr/sbin/automountd" in the process list then this is the "new" version of automounter (also called AutoFS). Using AutoFS will enable you to mount any type of filesystem which includes NFS Version 3. I think on 11.x you have the option of either start your automounter with the "old" or "new" version. Take a look at /etc/rc.config.d/nfsconf and settinf these vars would determine how are you going to start your automounter.
a) AUTOFS=0 and AUTOMOUNT=1 will start up the old automounter.
b) AUTOFS=1 and AUTOMOUNT=1 will start the new automounter.
The option b) is the one you should be using if you want to make automunter use version 3.


Jeff Schussele
Honored Contributor

Re: autofs - some mounts not using NFS 3

Hi Geoff,

Try stating explicitly vers=3 in the third field of your /etc/auto_master file.
Third field is where you can set any/all mount options.

If you use a direct map to mount these, the NFS mount options go in the 2nd field.

Although it's supposed to default to highest *common* version, it can't hurt to force it.

HTH,
Jeff
PERSEVERANCE -- Remember, whatever does not kill you only makes you stronger!
Geoff Wild
Honored Contributor

Re: autofs - some mounts not using NFS 3

Thanks for the info guys.

autofs=0 on the 11.0 boxes and 1 on the 11.i

I might try the "force" method in auto_master as well - either way I'll have to wait until out next outage...

Rgds...Geoff
Proverbs 3:5,6 Trust in the Lord with all your heart and lean not on your own understanding; in all your ways acknowledge him, and he will make all your paths straight.