Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

automount hangs but manual mount is fine on 10.01 E35

Dee_3
Regular Advisor

automount hangs but manual mount is fine on 10.01 E35

Hi-
I have an E35 HP-UX system on 10.01 that I want to automount an NFS file system. When automounting, it hangs without completing the mount. I attempted the automount command with the -T option to write to /var/adm/automount.log and here is what is in that log:
02.08.06 18:27:37 do_timeouts: enter
Aug 6 18:27:37 do_timeouts: exit
What puzzles me is that I can do a manual mount of this same configuration and it mounts and works fine, like this:
mount ip_addres:/E/DIRECTORY /tmp_mnt/DIRECTORY
Any help would be greatly appreciated.
Thanks, Terri Christensen.
4 REPLIES
Sajid_1
Honored Contributor

Re: automount hangs but manual mount is fine on 10.01 E35

Hi,

Did you set up the automount correctly? Did you check the daemons and see if it's running (check rpcinfo -p too). Check and see if you have this patch installed - PHNE_17248.

# man automount

HTH
learn unix ..
S.K. Chan
Honored Contributor

Re: automount hangs but manual mount is fine on 10.01 E35

This might be an rpc lockd problem. I've had NFS (automounter) hung on me occasionally when user try to login to a NFS client waiting for the home directory to automount but never happened. The exported FS however can be manualy mounted (like you said). Why don't you try resetting the rpc on the client, then the server, this can be done without affecting other "active" mounted FS.
# ps -ef|grep rpc
==> Kill the "rpc.lockd" and "rpc.statd" processes. You can do this without the "-9" in your kill command.
# cd /var/statmon
# mv sm sm.org
# mv state state.org
==> Now start "rpc.statd" and "rpc.lockd" processes.
# /usr/sbin/rpc.statd
# /usr/sbin/rpc.lockd
The network lock manager will now go through it's recovery to reclaim previous locks.
Dee_3
Regular Advisor

Re: automount hangs but manual mount is fine on 10.01 E35

Thanks for the replies. I checked and tried everything recommended but still am unable to automount. When /usr/sbin/automount is executing, it finally gave me a message of NFS Server (pid21711@/directory) not responding still trying. I'm still struggling with this. Any further help is appreciated. Thanks, Terri Christensen.
Dee_3
Regular Advisor

Re: automount hangs but manual mount is fine on 10.01 E35

Finally resolved this by using an /etc/nsswitch.conf file to look at /etc/hosts first and dns second. Thanks for the replies. Terri Christensen.