cancel
Showing results for 
Search instead for 
Did you mean: 

backspace does not work

SOLVED
Go to solution
Jim Booker
Advisor

backspace does not work

When I telnet to any of my hp unix servers, for some reason I have to use control backspace
instead of just plain backspace when I want to
backspace. Any ideas? Thanks!!!
7 REPLIES
Jay Newman
Frequent Advisor

Re: backspace does not work

Depending on your terminal (or emulator), your backspace key may be sending control-H or something other than what your unix servers are expecting.
If you can determine what character is being sent to the host when you press backspace, try entering the following into your .profile and log out and in:
stty erase "^H"
(in my case, my backspace sends control-H)
Try man stty for more info.
HTH

"Success is defined by getting up one more time than you fall down."
harry d brown jr
Honored Contributor

Re: backspace does not work

Check your termtype, on your hpux machine, if you can get to a unix prompt, type in echo $TERM

Make sure your telnet session matches. vt100 is usually a safe bet.
Live Free or Die
Rajeev Tyagi
Valued Contributor

Re: backspace does not work

Jim,

Can you check your stty settings for erase as follows.
#stty | grep erase
If it is not set for backspace then you can set it for your environment as follows.
#stty erase

Rajeev
Sanjay_6
Honored Contributor

Re: backspace does not work

Hi Jim,

I had the same problem, But i was using exceed - telnet to login into my unix box. The setting i was required to modify was
Select Host Name --> Edit Profile --> Terminal --> Keyboard Options --> Set Backspace to True Backspace.

I was earliar getting ^? when i use to press the backspace key.

Hope this helps
Sanjay
Richard Darling
Trusted Contributor
Solution

Re: backspace does not work

I get this problem intermittently on different terminals, and chose the lazy person's approach. I wrote a little script and called it "b". Whenever I have this problem I just enter b at the prompt.
Here it is:

#!/bin/sh
# this script sets erase to the backspace key
# located in /usr/bin
# created 05/08/1999 by Richard Darling

stty erase ^?
echo "the backspace key is now functional"
rdarling@southwickclothing.com
Steve Post
Trusted Contributor

Re: backspace does not work

The backspace key is ^?, or ^H, or something else. The term type is VT220, or VT100, or ANSI, or something else? Assuming I have a terminal type of: I don't care. And the backspace key is the sequence: I don't care.

I get the backspace key working this way...

I type "stty erase "
I press control and v at the same time.
I press what I "decree" to be the backspace key.
I hit the enter key.

There. It's fixed on whatever thingy you were using to connect to HP.

Re: backspace does not work

Hi Jim,
$stty erase

You can make any character as erase; such as
$stty erase k
The backspace work only when you press k. I have given just example.
You can look detail what characters and function assigned by just
$stty -a

Thanks
Zafar
Win/Win