Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

chatr(warning): dl_header_ext.size != sizeof(dl_header_ext)

SOLVED
Go to solution
Bill McNAMARA_1
Honored Contributor

chatr(warning): dl_header_ext.size != sizeof(dl_header_ext)

so what doe this mean then??

root @ cactus / # chatr /opt/app/oracle/product/8.0.6/bin/lsnrctl
chatr(warning): dl_header_ext.size != sizeof(dl_header_ext). Please update your
version of the linker.
/opt/app/oracle/product/8.0.6/bin/lsnrctl:

# what /usr/bin/ld
/usr/bin/ld:
HP aC++ B3910B A.03.27 Classic Iostream Library
HP aC++ B3910B A.03.27 Language Support Library
ld_msgs.cat: $Revision: 1.85 $
92453-07 linker command s800.sgs ld PA64 B.11.25 REL 001129

It works for me (tm)
5 REPLIES
Armin Feller
Honored Contributor

Re: chatr(warning): dl_header_ext.size != sizeof(dl_header_ext)

The warning is harmless. It is a matter of applications being linked
with newer linker versions in the future to eliminate this warning.
Armin Feller
Honored Contributor

Re: chatr(warning): dl_header_ext.size != sizeof(dl_header_ext)

It has been fixed in:

PHSS_22514 for 11.00
PHSS_22535 for 11i

Regards,
Armin
Bill McNAMARA_1
Honored Contributor

Re: chatr(warning): dl_header_ext.size != sizeof(dl_header_ext)

just to note tho' the patch didn't correct the warning ;(


# what /usr/bin/ld
/usr/bin/ld:
HP aC++ B3910B A.03.30 Classic Iostream Library
HP aC++ B3910B A.03.30 Language Support Library
ld_msgs.cat: $Revision: 1.85 $
92453-07 linker command s800.sgs ld PA64 B.11.33 REL 020603


root @ cactus /tmp # swlist -l fileset -a state | grep PHSS_26559
# PHSS_26559
PHSS_26559.C-ENG-A-MAN configured
PHSS_26559.C-INC configured
PHSS_26559.C-KRN configured
PHSS_26559.C-MIN configured
PHSS_26559.C-MIN-32ALIB configured
PHSS_26559.C-MIN-64ALIB configured
PHSS_26559.CAUX-ENG-A-MAN configured
PHSS_26559.CMDS-AUX configured
PHSS_26559.CORE-64SLIB configured
PHSS_26559.CORE-SHLIBS configured
PHSS_26559.LANG-MIN configured
PHSS_26559.PAUX-ENG-A-MAN configured
PHSS_26559.PROG-AUX configured
PHSS_26559.PROG-AX-64ALIB configured
It works for me (tm)
Bill McNAMARA_1
Honored Contributor

Re: chatr(warning): dl_header_ext.size != sizeof(dl_header_ext)

Congrats on the Cap!!

Have a nice weekend!!

Later,
Bill
It works for me (tm)
Theresa Patrie
Regular Advisor
Solution

Re: chatr(warning): dl_header_ext.size != sizeof(dl_header_ext)

This error means that the vendor needs to re-compile their code with the correct HP libraries. We had this happen on an Actel synthisis tool. It has no effect on how the tool runs. In our case, Actel needed to regenerate their executables using the updated HP libs (which they haven't done yet, btw). Seems that HP users are not a top priority with some vendors these days!
Theresa
This is my easy job!