cancel
Showing results for 
Search instead for 
Did you mean: 

dtfile - UNKNOWN icon

SOLVED
Go to solution
David Wight
Occasional Contributor

dtfile - UNKNOWN icon

Hi,

I am using HP-UX 11.
When I run dtfile from within a CDE session
an icon is displayed for each file and folder
but every icon is the 'UNKNOWN' icon.
If I double click on an icon it says:

There are no actions defined for UNKNOWN.

If I try to create a new file from within dtfile, say dave.txt, the selected icon is also
the UNKNOWN icon.

Do you know what could be causing this please.

Regards

Dave
2 REPLIES
rainer doelker
Valued Contributor
Solution

Re: dtfile - UNKNOWN icon

Hello David,

there are several item I have on this which you may check:

Does this affect all users? And if not, you may compare the output of "dttypes" of a non-operationa and a operational user.

Usually the icons are determined by typedefinitions in /usr/dt/appconfig/types// . There are some files.

If it affects only the one user (or even all incl. root) you may want to look into their $HOME/.dt directory and look for startlog and errorlog. I suspect if dtappgather or dtsearchpath have reported any error. A good job - especially for permission things would do "dr_dt" as well.

Is the system newly installed? Do you have CDE-Runtime patches? (swlist -l product |grep -i cde).

A really important question is "since when" does this problem appear. What has changed since it worked the last time without that behaviour ??

Hope this helps a little.
rainer
David Wight
Occasional Contributor

Re: dtfile - UNKNOWN icon

Rainer,

Thank you.
The problem applied to all users. I changed the
LANG variable and now everything is fine.

Regards

Dave