cancel
Showing results for 
Search instead for 
Did you mean: 

error sendmail

SOLVED
Go to solution
Jairo Campana
Trusted Contributor

error sendmail

hello since I can do so that it does not show localhost that I must modify
root [root@localhost.telefe.tdatacenter.com]
legionx
8 REPLIES
Sachin Patel
Honored Contributor
Solution

Re: error sendmail

Hi jairo,
I am not sure what you are asking here.
do you have entry in /etc/hosts file
127.0.0.1 localhost loopback

Sachin
Is photography a hobby or another way to spend $
Roger Baptiste
Honored Contributor

Re: error sendmail

hi,

if you want to set masquerade to hide the local host in the email id, then set the DM option in /etc/mail/sendmail.cf file.
(in older versions it is DY )

HTH
raj
Take it easy.
Mark Greene_1
Honored Contributor

Re: error sendmail

At the command line, run this:

mailq -v -d|pg

this will show you the basic setup for sendmail on the system, including host and domain info.


Some files to check:

/etc/resolv.conf for name resolution order

/etc/hosts for hostname setup as state (make sure the fully qualified host name, i.e. with domain, is listed)

/etc/mail/sendmail.conf - check the DS parameter if you have an internal relay host to make sure it has been properly added.

If you make any changes, stop and restart the sendmail daemon:

/sbin/init.d/sendmail stop
/sbin/init.d/sendmail start

--
mark
the future will be a lot like now, only later
Jairo Campana
Trusted Contributor

Re: error sendmail

I modify this, and not have domain
# ... define this only if sendmail cannot automatically determine your domain
Dj$w.telefe.tdatacenter.com

I must modify
# who I masquerade as (null for no masquerading) (see also $=M)
DMtelefe.tdatacenter.com

my server of relay is:

# "Smart" relay host (may be null)
DSnms1.noctic.tdatacenter.net.ar

this is correct?



legionx
Roger Baptiste
Honored Contributor

Re: error sendmail


<# ... define this only if sendmail cannot automatically determine your domain
Dj$w.telefe.tdatacenter.com >>

You need this only if you do not have DNS setup for hostname reolution.

Rest of the settings are correct.

HTH
raj
Take it easy.
Jairo Campana
Trusted Contributor

Re: error sendmail

i have a domain
my configuration is: sendmail.cf
#Dj$w.Foo.COM
DMjoshua.campana.com

my relay is:

# "Smart" relay host (may be null)
DSnms1.noctic.tdatacenter.net.ar

but I continue obtaining
[root@localhost.localdomain]
when send an email from the server

my /etc/hosts :
127.0.0.1 whdlx01 localhost localhost.localdomain

my resolv.conf is
search hello.example.net.ar hello2.example.net.ar
hello3.tdatacenter.net.ar
nameserver 172.31.195.133

legionx
Jairo Campana
Trusted Contributor

Re: error sendmail

sorry, i have dns
the line :
my configuration is: sendmail.cf
#Dj$w.Foo.COM

its comment
legionx
Roger Baptiste
Honored Contributor

Re: error sendmail

hi,

Two things:

The file to be changed is /etc/mail/sendmail.cf
(just in case you are trying to change /etc/sendmail.cf)

And also try restarting the sendmail daemon before sending the mail.
/sbin/init.d/sendmail stop
/sbin/init.d/sendmail start

-raj
Take it easy.