Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

inability to handle file names greater than 32 characters

Rene Mendez_4
Super Advisor

inability to handle file names greater than 32 characters

Hello

OS HPUX 11.11 patch bundle Dec 2004,
Install sybase 12.5.2 and present error.

An unhandled error occurred -- specify system property

"is.debug" for more information.



Workaround: This is due to the operating system’s inability to handle file

names greater than 32 characters and can be corrected with OS patches. For OS

patch requirements, see the Installation Guide for HP-UX.

Exist patch for long names ??


Regards
Rene
4 REPLIES
A. Clay Stephenson
Acclaimed Contributor

Re: inability to handle file names greater than 32 characters

I think this is an erroneous message. The limit is 255 characters. The one exception is hfs filesystems explicitly built with the -S option to limit the length of filenames. Man mkfs_hfs for details. I very much doubt you are using hfs filesystems so this almost certainly is not your problem. What is the errno value reported?
If it ain't broke, I can fix that.
Bill Hassell
Honored Contributor

Re: inability to handle file names greater than 32 characters

There is only one filesystem where this is a possibility. The HFS filesystem has an option to limit filenames to 14 characters, but the default is 255. Unless the system administrator created a bunch of HFS filesystems (very unlikely), there is no short filename limit. The error message is misleading so you'll have to get Sybase to explain what the real error might be.


Bill Hassell, sysadmin
Cesar Sanchez Muñoz
Occasional Visitor

Re: inability to handle file names greater than 32 characters

Hi, You must mount your cdrom with this option #mount -o rr /dev/dsk/c1t2d0 /cdrom

I had this problem and with this option was eliminated the problem.

Regards,

Juan Carlos
Stephen Chaung
Occasional Visitor

Re: inability to handle file names greater than 32 characters

Just verified that mounting the cdrom with those flags works! I've also been trying to find a solution to this. Thanks so much.