Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

maxfilles and maxfiles_lim change?

SOLVED
Go to solution
Chetan_5
Frequent Advisor

maxfilles and maxfiles_lim change?

Folks,
I recently changed the above paramters on an L class 11.00 box since it was logging messages of "Too many open files". The parameter values were changed from 2048 to 4096.
SAM did not allow me to change the values, so I modified the system file and generated the kernel manually. The system came up fine with the new kernel, but there are some discrepancies in the outputs of the kmtune, sysdef, ulimit and sam??
kmtune is still showing 2048
sysdef is showing 4096
SAM shows 4096, but it pops up a message that these parameters have to be reduced to 2048??
ulimit shows nofiles at 4096?

Has anyone seen this before?
4 REPLIES
V. V. Ravi Kumar_1
Respected Contributor

Re: maxfilles and maxfiles_lim change?

Hi,
you may require to install patch for this.
patch PHKL_24487 fixes this for SAM. check out this.
this is the description
PHKL_24487:
( SR: 8606108859 DTS: JAGab81563 )
Using SAM, tunable kernel parameter maxfiles and
maxfiles_lim can not be set to higher than 2048.

hope this helps

ravi
Never Say No
V. V. Ravi Kumar_1
Respected Contributor

Re: maxfilles and maxfiles_lim change?

hi,
you may do this manually by editing the core-hpux file. SAM refers this file for limits.

grep maxfiles /usr/conf/master.d/core-hpux
*range maxfiles<=2048
if the value shows 2048 change that to 60000 (this is the max) and try with changing maxfiles using SAM. reboot the machine. i hope problem should be solved

regards
ravi
Never Say No
Sridhar Bhaskarla
Honored Contributor
Solution

Re: maxfilles and maxfiles_lim change?

Hi,

I guess only descripancy is with kmtune. As mentioned, you can install patch for SAM to allow larger values for max_files and max_files_lim parameter.

Looks like your /stand/system is not uptodate. I would do the following

cp /stand/system /stand/system.old
/usr/lbin/sysadm/system_prep -s /stand/system

kmtune -l -q maxfiles (and maxfiles_lim)'

Make sure you see both planned and current at the same value.


-Sri
You may be disappointed if you fail, but you are doomed if you don't try
Chetan_5
Frequent Advisor

Re: maxfilles and maxfiles_lim change?

SHridhar hit the nail on the head. Too much automation has its downside. I did forget to copy the new system file from build. After copying it, it corrected the discrepancy between kmtune and other indicators.

I will have to schedule the patch installation to correct sam at a later date.

Thanks fellas...