Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

messages on console terminal

Dave Chamberlin
Trusted Contributor

messages on console terminal

I have a k460 running 10.20 . Recently, messages started appearing on my console terminal. The message repeats every several seconds and I find it very irritating. The message is not from my system, but another system in our network, but the network folk seem unable to make it stop. the message is:

process_name_refresh_request: unicast name registration request received for name NETWORK_MANAGER<00> from IP 10.2.51.4 on subnet UNICAST_SUBNET.
[2000/09/12 09:23:33] nmbd/nmbd_incoming_requests.c(181)
Error - should be sent to WINS server

My questions are:
1 - how can this appear on my console?
2 - how can I prevent it?

Any input appreciated..

Dave Chamberlin
9 REPLIES
Cheryl Griffin
Honored Contributor

Re: messages on console terminal

By chance, are you using SAMBA? The messages may be related to SAMBA.
"Downtime is a Crime."
Cheryl Griffin
Honored Contributor

Re: messages on console terminal

Dave,
I did a search from Google (www.google.com) and there is a wealth of information out on the internet regarding these messages.

See if this link takes you there: http://www.google.com/search?q=process_name_refresh_request%3A+unicast+name+&btnG=Google+Search
"Downtime is a Crime."
Dave Chamberlin
Trusted Contributor

Re: messages on console terminal

Indeed the messages are SAMBA messages. I was told that samba was installed on my system as a test some time ago and is not used. Will killing it on my machine make the messages stop?
Rick Garland
Honored Contributor

Re: messages on console terminal

If SAMBA is not being used there is no reason to stop the process.
Also prevent it from starting at boot up time as well.
Alan Riggs
Honored Contributor

Re: messages on console terminal

Yes, stopping samba whould cause teh messages to stop. I second the recommendation that you disable the startup script as well.
Dave Chamberlin
Trusted Contributor

Re: messages on console terminal

How do I disable samba from running? Do I simply remove the S900samba in /sbin/rc.2? Do I need to edit /etc/inetd.conf to comment out the samba lines? Thanks..
Rick Garland
Honored Contributor

Re: messages on console terminal

Look to see if there is a /etc/rc.config.d/samba or smb (or something like that) file.
This is the file that you put the '1' to start or the '0' to not start. Put a '0' into the spot that would tell the system to start samba.

As an alternative, you could mv the /sbin/init.d/S* script that tell the system to start samba. With no startup script, it will not start.

The /sbin/init.d/* files typically look into the /etc/rc.config.d/* files for start instructions. This is where the '1' and the '0' come in.
Alan Riggs
Honored Contributor

Re: messages on console terminal

If teh system was built according to standards, then the S900samba file in /sbin/rc.2 will be a soft link to a samba file in /sbin/init.d. In the file, there should be a case statement which parese the start|stop|start_msg|stop_msg flags. In the start section you will see a test like:

if [ $SAMBA -eq 1 ] ; then
(code to start Samba)

This indicates the environmental variable which determines whether to start Samba at boot. The variable should be set in a file in teh /etc/rc.config.d/ directory. Again, acording to standards this should be named samba. Edit that file to set the SAMBA variale to 0.

Even if the installation is not according to standard, following this path should show you where the startup is defined.
Dave Chamberlin
Trusted Contributor

Re: messages on console terminal

I removed the scripts from rc2.d and init.d - as it looked, it was not a correct installation, as the same script was in both dirs (no link) and the conf file in rc.config did not set a start/stop option. The messages are gone now. Thanks