cancel
Showing results for 
Search instead for 
Did you mean: 

mount cdrom problem

SOLVED
Go to solution
ANDRE David
Occasional Advisor

mount cdrom problem

hi,

i try to mount a cdrom on HpUX 11.11 with this command :

$mount -o ro /dev/dsk/c3t2d0 /cdrom
the cdrom is mounted but the file is not correct

ll /cdrom

Readme.html;1
...

All files have ";1" at the end
Which option can i use to have a good file? ( Readme.html )

If i use cdcase, there isn't ";1" but all files are lowercase. ( it's not good... )

Thanks.
11 REPLIES
Massimo Bianchi
Honored Contributor

Re: mount cdrom problem

hi,
you could try with pfs_mount, but it can cause a reboot when care is not taken.


If you wish, latest mount patches allow you to mounf pfs without the need for special demons.

PHKL_28025

It requires a reboot.


extract from notes:

PHKL_26520:
( SR:8606244607 CR:JAGae11092 )
PHKL_25760 introduced behavior that can result in problems
accessing files from mounted CDFS file systems, for example
CD and DVD media. The cdfs driver included in PHKL_25760
may show and match all file names as lower case characters.


Massimo
twang
Honored Contributor
Solution

Re: mount cdrom problem

Are you mounting CD from Oracle?
If yes, for hpux, you should follow the mounting instructions:

# nohup /usr/sbin/pfs_mounts &
# nohup /usr/sbin/pfsd &
# /usr/sbin/pfs_mount -t rrip -x unix /dev/dsk/c5t2d0 /SD_CDROM

if there is no /etc/pfs_fstab, create it as follows:
# cat /etc/pfs_fstab
/dev/dsk/c5t2d0 /SD_CDROM pfs-rrip xlat=unix 0 0

Hope it helps!
Sunil Sharma_1
Honored Contributor

Re: mount cdrom problem



try -o cdcase option
Sunil
*** Dream as if you'll live forever. Live as if you'll die today ***
BFA6
Respected Contributor

Re: mount cdrom problem

Hi,

If it is an Oracle cd it will have to be mounted using pfs_mount.

Also don't forget to unmount using pfs_umount

Regards,

Hilary
V. Nyga
Honored Contributor

Re: mount cdrom problem

Hi,

option cdcase will eliminate ";1" and shows all files with lowercase - not good?
You can try RockRidge. But for the option rr you will need patches (HP UX 11):

PHKL_28060
PHKL_26450
PHCO_26449

I don't know if you cdrom is RockRidge-formatted. But there are no more possibilities

I had a thread with cdrom burning and reading:
http://forums.itrc.hp.com/cm/QuestionAnswer/1,,0xac692d88ce9cd711abdc0090277a778c,00.html

Good luck
Volkmar
*** Say 'Thanks' with Kudos ***
V. Nyga
Honored Contributor

Re: mount cdrom problem

Hi again,

look here ("New patches will eliminate pfs_mount for CD-ROMs"):
http://www4.itrc.hp.com/service/cki/docDisplay.do?docLocale=en_US&docId=200000067424041

My patches were for 11.0, there you can find the same for 11.i

PHCO_25841
PHKL_26269
PHKL_28025

because pfs_mount could cause problems.

Regards
Volkmar
*** Say 'Thanks' with Kudos ***
Bill Hassell
Honored Contributor

Re: mount cdrom problem

PFS is essentially obsolete due to problems and the recently added patches for RockRidge formats. After adding the above patches for your 11.11 system, use the -orr option to mount your CD. The UPPERCASE.EXT;1 format is standard ISO-9660 format for files. But the CDROM standard (aka, the Yellow book) defines additional directories that are used to translate the 8.3;version format into long filenames, etc. These 3 patches will now access the additional directories on the CD and display the desired filenames. NOTE: HP-supplied CDs (for HP-UX) are written in a proprietary (non-standard) format which is understood by the native CDFS code in HP-UX.


Bill Hassell, sysadmin
Indira Aramandla
Honored Contributor

Re: mount cdrom problem

Hi,

The reason is the file type on the CD is not of UNIX.

When you user pfs_mount with the option -x unix it will translate to file type UNIX.

To user pfs_mount, you need the pfs_mountd and pfs running.

The do the following

# nohup /usr/sbin/pfs_mounts &
# nohup /usr/sbin/pfsd &
# /usr/sbin/pfs_mount -x unix /dev/dsk/c5t2d0 /cdrom

This will work.
Never give up, Keep Trying
R. Allan Hicks
Trusted Contributor

Re: mount cdrom problem

I think that you meant

nohup pfs_mountd& instead of nohup pfs_mounts&

also do not forget the
/etc/pfs_fstab has to be built

example:

/dev/dsk/c3t2d0 /SD_CDROM pfs-rrip xlat=unix 0


Your device and mount point will vary, but the rest of the line will be the same.

"Only he who attempts the absurd is capable of achieving the impossible
Caesar_3
Esteemed Contributor

Re: mount cdrom problem

Hello!

Try like this:
mount -o cdcase /dev/dsk/c3t2d0 /cdrom

Caesar
Yogeeraj_1
Honored Contributor

Re: mount cdrom problem

hi,

i prefer to use my script which allows me to both mount and unmount my Oracle cds.

It uses pfs_mount.

hope this helps!

regards
Yogeeraj
No person was ever honoured for what he received. Honour has been the reward for what he gave (clavin coolidge)