Simpler Navigation coming for Servers and Operating Systems
Coming soon: a much simpler Servers and Operating Systems section of the Community. We will combine many of the older boards, and you won't have to click through so many levels to get at the information you need. If you are looking for an older board and do not find it, check the consolidated boards, as the posts are still there.
cancel
Showing results for 
Search instead for 
Did you mean: 

mount error

SOLVED
Go to solution
MikeL_4
Super Advisor

mount error


I have pfs_mounted a PeopleSoft CD in a local hpux 11.0 and I want to install it on a remote hpux 11.0. I have the CD mounted on local server using pfs_mount, but when I try to mount on remote server I get:

mount servera:/cdrom /cdrom
Too many levels of remote in path

9 REPLIES
Steven E. Protter
Exalted Contributor

Re: mount error

Turn off pfs_mount daemons and try the script i'm attaching. It might work.

pfs_mount is already using NFS which may be the trouble.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Marvin Strong
Honored Contributor

Re: mount error


I think you need to do pfs_exportfs for the cdrom mount point and mount that on the remote host.
James A. Donovan
Honored Contributor

Re: mount error

better yet as a long term solution do away with pfs_mounts altogether by patching your systems.

the following is "borrowed" from http://www.cmve.net/~merijn/

Do not use pfs_mount!. Install the Rock-Ridge extension patches instead and never worry about these problems. For HP-UX 11.00 you will need forget all about PFS and install PHKL_26448 (now superceded by PHKL_28060), PHCO_26449, and PHKL_26450 to have HP-UX recognize those file systems automatically on mount! For HP-UX 11.11 (11i) you need PHCO_25841, PHKL_26269, and PHKL_25760 (now superceded by PHKL_28025).

No need thereafter to use -o cdfs to mount anymore, provided you enter the CD drive in /etc/fstab like this:

/dev/cd0 /cdrom cdfs ro,rr,noauto 0 0
Remember, wherever you go, there you are...
MikeL_4
Super Advisor

Re: mount error

Long term solution will work, but not now.

I tried the mount command as suggested, and
received:
# /usr/sbin/mount -F cdfs -e -o ro,rr
/dev/dsk/c2t0d0 /cdrom
mount: illegal file system specific option rr
usage: mount [-l][-v|-p]
mount [-F FStype][-eQ] -a
mount [-F FStype][-eQrV][-o specific_options]
{ special | directory }
mount [-F FStype][-eQrV][-o specific_options]
special directory
#

so I did without the rr and it mounted, but
developers said it's not mounted correctly.
I gues in the pfs_mount it does a translate to unix and mount doesn't give that option that I can find..

/dev/dsk/c2t0d0 /cdrom pfs-rrip xlat=unix 0 0
Marvin Strong
Honored Contributor

Re: mount error

once you get the CD pfs mounted on say /cdrom

add an entry /etc/pfs_exports or create if its not there.

/cdrom ro=host.fqn

# pfs_exportfs -a

Then you should be able to mount the cd on the other host.


Marvin Strong
Honored Contributor

Re: mount error

actually the entry should be

/cdrom ro=remotehost.fqn

for example here I have:

/cdrom ro=hp19rm1.xxx.com

James A. Donovan
Honored Contributor
Solution

Re: mount error

You must use pfs_mount on the remote system as well, not mount.

Here is a guid on how to do the whole process.

http://www1.itrc.hp.com/service/cki/docDisplay.do?docLocale=en_US&docId=200000063235893
Remember, wherever you go, there you are...
MikeL_4
Super Advisor

Re: mount error

When I issue the mount on the remote server I still get error:

# mount uxas01:/cdrom /cdrom
Too many levels of remote in path
#
MikeL_4
Super Advisor

Re: mount error

Jim, thanks alot, that document solved the problem..