cancel
Showing results for 
Search instead for 
Did you mean: 

oracle 1562 error

SOLVED
Go to solution
Pieter_5
Advisor

oracle 1562 error

Hi,

I just increased the tablespace by adding a datafile to it. THe users have a new run but while they tried to import a lot of data they receive a oracle 1562 error. The error claims that it cannot extent the rollback segment because the max extents are reached. What to do next?
5 REPLIES
Ian Lochray
Respected Contributor

Re: oracle 1562 error

Andre,
I can think of a couple of options.

If the users are using the Oracle "imp" utility then you can specify the "commit=y" option on the command line. This will commit the data every so often rather than for each whole table, cutting down the amount of rollback required.

If they are not, you need to alter the storage parameters on your rollback segments. Check the current settings from sqlplus when logged on as the system user with:-
select * from dba_rollback_segs;
You can then alter the storage parameters with commands like :-
alter ROLLBACK SEGMENT RBS03 STORAGE (MAXEXTENTS 249);

You may also have to extend the size of your rollback tablespace.
John Jayaseelan
Super Advisor
Solution

Re: oracle 1562 error

Andre,

Try to do this import when no other processes are utilising the Roll back segments.
Steven E. Protter
Exalted Contributor

Re: oracle 1562 error

Why not this?

alter ROLLBACK SEGMENT RBS03 STORAGE (MAXEXTENTS UNLIMITED);


SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Jean-Luc Oudart
Honored Contributor

Re: oracle 1562 error

I would not put an unlimited nbr extents for a rollback segment.

Tune it . Change extent size.

As said, you can use commit=Y .
Also change the buffer parameter
BUFFER=

That will reduce the number of commits.

Rgds,
JL
fiat lux
Brian Crabtree
Honored Contributor

Re: oracle 1562 error

Andre,

Take a look in the v$rollstat view. There is a column called "AVEACTIVE". A good idea is to double this column (try to keep it in round 1m or 500k sections though) for your initial extent, with 8-10 minextents for each segment.

If that doesn't work, 50m extents with 8 minextents normally works. =)

Brian